Problems after installation of phpswitcher 5.0.3, one Domain isnt working anymore

  • Hello I-MSCP Members.


    I have big problems after installation of phpswitcher 5.0.3 over latest older 4.xx version.

    OS Version:

    Debian GNU/Linux 9 \n \l

    Linux rr-rechnung 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3.1 (2019-02-19) x86_64 GNU/Linux



    IMSCP version 1.5.3 version with latest patch leve.

    Plugins:

    pasted-from-clipboard.png



    Error message after update to 5.0.3

    Plugin::PhpSwitcher::update: Died at /var/www/imscp/gui/plugins/PhpSwitcher/backend/PhpSwitcher.pm line 1218.


    websites didnt work after update.



    After that i installed the plugin a second time.


    Plugin installation was sucessful after the second try, but websites didnt work.


    My Domain overview

    pasted-from-clipboard.png


    after a few minutes...

    pasted-from-clipboard.png



    PLS help me, thank you very much!!!

    Edited 3 times, last by reitbrud ().

  • reitbrud

    Changed the title of the thread from “Massive Probleme nach Installation vonphpswitcher 5.0.3, esl laufen keine Seiten mehr!” to “Massive Probleme nach Installation von phpswitcher 5.0.3, es läuft eine Domain nicht mehr”.
  • After looking into the imscp database i have seen this Error message:

    Plugin::PhpSwitcher::_overrideHttpFpmServerSettings: Couldn't find PHP version for the rr-rechnung.at domain. at /var/www/imscp/gui/plugins/PhpSwitcher/backend/PhpSwitcher.pm line 828.


    Plugin::PhpSwitcher::_overrideFpmUdsPath: Couldn't find PHP version f


    pasted-from-clipboard.png


    php default server (i-mscp) version is 5.6.

    with phpswitcher i have installed version 7.1.11.

    Edited once, last by reitbrud ().

  • reitbrud

    Changed the title of the thread from “Massive Probleme nach Installation von phpswitcher 5.0.3, es läuft eine Domain nicht mehr” to “Problems after installation of phpswitcher 5.0.3, one Domain isnt working anymore”.
  • Nuxwin

    Added the Label to be investigated
  • I ve located the error.


    I have imscp php version 5.6.40


    i have installed phpswitcher version 5.6.40 and 7.1.xx.


    After upgrade to phpswitcher 5.0.3 the software didnt find the phpswitcher version 5.6.40 and this was the error.

    Maybe phpswitcher Software have the Problem to differ between identical psw and php versions?


    The solution was to set status from all domains which hadnt the Status OK to OK and switch one time the php version which was before set to phpswitcher version 5.6.40 to 7.1 and back to 5.6, and the domain started working.


    Now i have no phpswitcher Version 5.6.40, i would need it for the imagick support. But at the moment no problem, because i will switch in a few days to php 7 if i have updated my code.


    thanks

  • Hello,


    yes, I had the same mistake and fixed it that way.


    Unfortunately, I have to do it after every server reboot.

    phpswitcher wants to create a php fpm for the standard php version or does not find it


    greeting

    Viktor

    - Distribution: Debian | Release: 8.10 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)

    - LetsEncrypt (v 3.5.0), PhpSwitcher (v 4.0.3), RoundcubePlugins (v 2.0.2)

  • And the status of all PHP versions in the phpswitcher admin interface is?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Hi,


    the status id 'ok'.


    Oh I just see that I still have PhpSwitcher 5.0.2 installed.

    Must first make the update and see if there the error is still there.


    greeting

    Viktor

    - Distribution: Debian | Release: 8.10 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)

    - LetsEncrypt (v 3.5.0), PhpSwitcher (v 4.0.3), RoundcubePlugins (v 2.0.2)

  • Assumption...


    Unfortunately, I have to do it after every server reboot.

    phpswitcher wants to create a php fpm for the standard php version or does not find it

    Assumptions... Not your thread... No enough details...



    Too much assumptions in that thread... and no relevant information.

    Please, when you report an issue, don't mix the problems, don't make assumptions without knowing how thing are working, give us all relevant information and only those information. We don't care about your assumptions which don't help.


    When you report an issue for the PhpSwitcher plugin you need give us the following information:

    1. Your distribution and its codename
    2. The i-MSCP version you're running
    3. The i-MSCP httpd server implementation you're using (Fcgid, FPM)
    4. The PhpSwitcher plugin affected by the problem
    5. The PhpSwitcher plugin version from which you're updating (if your're updating)
    6. The exact error message
    7. The PHP version status for which you have a problem
    8. Whether or not the involved PHP version is a compiled or packaged PHP version
    9. The exact steps (without any assumption) to reproduce the problem

    For now, I'm closing this thread because there are mixed problems that are true or not... You're free to open a new thread (your own thread and only one thread per problem), providing us with all relevant information.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Nuxwin

    Closed the thread.
  • Nuxwin

    Set the Label from to be investigated to unreproducible