Upgrade / Migration from very old i-MSCP 1.1.21 / 2014

  • Hello everybody,

    I have a rented server which is going offline at the end of the month and i need to migrate it to a new server, I've searched the forums but at the moment it doesn't seem to be an easy way to upgrade / migrate a version this old of i-MSCP.

    My system is an Ubuntu 16.04 with i-MSCP version 1.1.21 Build: 20141230 Codename: Eagle and I want to migrate it to a brand new Ubuntu 18.04 with the latest i-MSCP 1.5.3.

    The problem is that i currently have 46 Domains, 8 Subdomains, 3045 e-mail accounts =O, 38 FTP accounts, 45 sql databases, migrating them manually like I did on a previous server this old which only had 6 domains would be a nightmare. (took me 4/5 hours to manually move the previous one)

    My question is : Does anyone know an easier way to make the upgrade ? Maybe a script to update the SQL databases to the latest format ? From what I could tell, if the SQL is ok, i could just install from scratch the latest version.

    The server is a production server so a larger than 1h downtime would be a problem.

    I would like to be able to upgrade the current server to Ubuntu 18.04, than upgrade the i-MSCP to 1.5.3 so when it's time to move I won't have any surprises.

    Any ideas are welcomed.


  • You can try directly upgrading to i-MSCP 1.5.3 after copying all necessary files to the new server. You can search the forum for migration relating questions. This isn't only a question of SQL tables.

    If this does not work, you have to upgrade i-MSCP on the old server (or a copy) first, as Ubuntu 18.04 is only supported by i-MSCP 1.5.3's latest build.

    If 1h downtime is a problem, you really should test upgrading on a cloned server and from start applying patches and upgrades to critical software regulary.

  • @f4Nm1Z9k2P

    The problem is, I already tried that, I have a free virtual machine which I can play around with in a safe environment, i basically copied the i-mscp database, config files and /var/www/imscp folders to re-create the original server on a fresh VM with Ubuntu 16.04. i-MSCP was working properly, than I downloaded version 1.5.3 and tried to upgrade and got a bunch of sql errors which I had no idea how to fix. I even tried to upgrade to an earlier version first (1.3.x), this time there were different errors and the daemon still won't compile, it's a real mess, that's why I thought maybe somebody else went through this and has a better idea on how I could upgrade / migrate successfully.

    As a side note, I never would have allowed i-MSCP to get this old without updating it regularly (i'm an update freak) I took over administration a few months ago from a previous admin who left all the servers in terrible mess with no updates for years. Now i'm playing catch-up with all of them.

  • So, i tried first the upgrade directly to 1.5.3 on the VM, resulted in the following error :

    1. Error was: │
    2. iMSCP::SystemUser::addSystemUser: usermod: directory /var/www/imscp/gui exists
    3. Error was: │
    4. iMSCP::SystemUser::addToGroup: Invalid group or username

    The, i tried to upgrade from 1.3.9, resulting in the following error :

    1. │ Error was:
    2. │ main::setupDatabase: [ERROR] An i-MSCP downgrade attempt has been detected. Downgrade is not supported.
    3. │ Stack trace:
    4. │ #0 {main}

    Next i'm going to delete the entire installation, dump again the sql backup of version 1.1.21 and try again to upgrade directly to 1.3.9 first.

  • i would at first upgrade to 1.3.0 and then to 1.5.3

  • Bulli

    Tried also 1.3.0, got the following error :

    1. Error was:
    2. │ iMSCP::Stepper::_callback: Initialization vector must be exactly 8 bytes long when using Crypt::Blowfish cipher at /root/imscp-1.3.0/engine/PerlLib/iMSCP/Crypt.pm line 427

    Each version i try gives out a completely different error X(

  • Tried both ways, but by deleting /var/www/imscp i found out that in most cases the installer progresses much further before it spits out an error, if I leave the original /var/www/imscp i get maybe 4-5 steps before it crashes, if i delete it i go 10-11 steps :D