How to use/create/manage own name server

  • Hello All,

    First of all, Happy new year to you all.

    I am not a DNS guru at all, and since 3 weeks now I am trying to create my own Name Server to be used with my domain, however I am always failing to accomplish that.

    Can someone help me and point me to the right direction?

    This is how my setup looks like now. Let say my domain is

    Domain name is registered via Godaddy. I am using where I can create all record needed to point domain to my server. So at this stage, Name Servers for the is setup to use the one from

    Al working with this setup.

    However, I would like to set this up to look more professional, so I want to have a name server like NS1.DOMAIN.COM

    I have found similar articles related to I_MSCP, but for some reason did not work for me: How to configure DNS for a target Domain

    This is what I tested with.

    Under Godaddy, manage DNS for the, I have created two hostname. NS1 and NS2, which pointed to my server.

    After a while, I was able to ping NS1.DOMAIN.COM and the correct IP was displayed.

    Once this hostname was confirmed to work, I have changed the DNS of, and pointed to use my own CUSTOM nameservers, the NS1.DOMAIN.COM and NS2.DOMAIN.COM

    I waited 48 hours for the change to take affect, but then nothing worked anymore.

    I was still able to ping NS1DOMAIN.COM or NS2.DOMAIN.COM

    However I was unable to ping DOMAIN.COM. ping was not able to resolve the

    On my server, DOMAIN.COM is correctly added. I also tested and created DNS ressource record such as A, MX records for this domain, but did not fixed the issue.

    So based on above link: Usage of i-MSCP DNS server (You've choosen bind9 for DNS server during i-MSCP setup) -> This is how my setup looks like, but still not working.

    Can someone help me out and let me know what I am doing wrong?

    Thank you.



  • FloRet88

    Added the Label not i-MSCP related
  • Hello FloRet88,

    I am not sure if you are right or not.

    I have followed exactly what was wrote by I_MSCP admin:


    I. Usage of i-MSCP DNS server (You've choosen bind9 for DNS server during i-MSCP setup)

    Here, I assume that the domain has been already created in the i-MSCP panel.

    • Your customer must register a glue record through the registrar interface: -> <ip>. Note that this can be take a bit time to be recorded.
    • Once that the glue record is ok, your customer must change the DNS server through the registrar interface. Here, he must use

    Note that the <ip> tag must be replaced by the IP that you assigned to the customer when you have created the domain through the i-MSCP panel

    Note also that here, I've described the usual procedure. Some registrars make the procedure more simpler. E.g, when you change the nameserver, they also register the glue record into the Registry.

    For namecheap, see:


    If bind9 was selected during I_MSCP setup, then I presume I_MSCP should manage the issue. I do not see anything in I-MSCP documentation saying that I will have to manually go to my ubuntu settings to make my nameserver working.

    I have another domain registered via Namecheap, and I also followed exactly what mentioned above, and still, I am able to ping the nameserver I have created, but unable to ping the main domain.

  • This can be closed.

    Issue was really simple.

    Port 53 was actually closed, that was the reason why the issue happened.

    I have opened the port for DNS, and all started working.

  • FloRet88

    Closed the thread.