SQLSTATE[HY000] [1045] Access denied for user 'imscp_master'@'wwwold' (using password: YES)

  • ich hänge jetzt seit 2 Tagen an der Installation

    ich überlasse alles dem Installscript der 1.5.3 auto, externer SQL, alle IP, roundcube Proftp

    der Server ist unter Ubuntu neu installiert


    Distributor ID: Ubuntu

    Description: Ubuntu 16.04.4 LTS

    Release: 16.04

    Codename: xenial


    Code
    1. [ERROR] Servers::sqld::mysql::installer::_setupDatbase: [ERROR] Couldn't establish connection to the database: SQLSTATE[HY000] [1045] Access denied for user 'imscp_master'@'wwwold' (using password: YES)


    wo zum Henker kommt dieses wwwold her ?


    der MySql Server hat die Nur INTERNE IP 10.1.X.X es gibt keinerlei einragung NEUEN Server mit wwwold für die 10.1.X.X


    hosts

    • 10.1.0.1 intranet
    • 10.1.0.2 db
    • 10.1.0.4 www
    • 10.1.0.6 mail

    der Installer legt warum auch immer die User mit der Öffentlichen und nicht mit der privaten IP an ?

    • imscp_master 144.76.1XX.XXX Ja ALL PRIVILEGES Ja Rechte ändern Rechte ändern Exportieren Exportieren
    • imscp_user 144.76.1XX.XX Ja ALL PRIVILEGES Ja Rechte ändern Rechte ändern Exportieren Exportieren
    Code
    1. Stack trace:
    2. #0 /var/www/imscp/gui/library/iMSCP/Database.php(103): PDO->__construct('mysql:host=10.1...', 'imscp_master', 'B3lDLOKf1snmp0...', Array)
    3. #1 /var/www/imscp/gui/library/iMSCP/Database.php(159): iMSCP_Database->__construct('imscp_master', 'B3lDLOKf1snmp0...', 'mysql', '10.1.0.2', 'imscp', Array)
    4. #2 /var/www/imscp/gui/library/iMSCP/Application.php(622): iMSCP_Database::connect('imscp_master', 'B3lDLOKf1snmp0...', 'mysql', '10.1.0.2', 'imscp')
    5. #3 /var/www/imscp/gui/library/iMSCP/Application.php(288): iMSCP\Application->initDatabase()
    6. #4 /var/www/imscp/gui/library/imscp-lib.php(44): iMSCP\Application->bootstrap('/etc/imscp/imsc...')
    7. #5 /var/www/imscp/engine/setup/updDB.php(28): require_once('/var/www/imscp/...')
    8. #6 /var/www/imscp/engine/setup/updDB.php(46): upddb_process()
    9. #7 {main}


    [ERROR] autoinstaller::Functions::install: An error occurred while performing installation steps

  • Nuxwin

    Added the Label not i-MSCP related
  • The problem here is not bound to i-MSCP. You use an external SQL server so you must make sure that you can connect to it.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • oh yeah

    from shell ich test it for and backward

    and i have access from all machines and from the I-MISP machine as root to ....

    why you think that ich have it not testet ??


    sorry ich dache das ist der German Corner da bleibt ich mal bei deutsch

    französich kann ich zwar auch aber mit der Sprache hapert es :-)


    >> der Installer legt warum auch immer die User mit der Öffentlichen und nicht mit der privaten IP an ?

    • >> imscp_master 144.76.1XX.XXX Ja ALL PRIVILEGES Ja Rechte ändern Rechte ändern Exportieren Exportieren
    • >> imscp_user 144.76.1XX.XX Ja ALL PRIVILEGES Ja Rechte ändern Rechte ändern Exportieren Exportieren

    wie könnte imcp denn sonst die USER mit der FALSCHEN IP anlegen ?

    deswegen fällt der Installer auf die schnauze :-) 

    da liest der Installer etwas aus was nicht zu den angegebenen Daten passt

    kann ja mal vorkommen

    ist auch keine erklärung für das "wwwold" da alle zugriffe ausschließlich über IP und keine DNSeinträge laufen und wwwold auf keiner der beteiligten Maschinen eingetragen ist


    ich habs jetzt prakmatisch gemacht und die User ALLE von hand angelegt (bin ja groß kann das auch wenn es sein muss :-) )

  • Sokoban

    1. While i-MSCP setup, you need to enter the SQL server host: 10.1.0.2
    2. While i-MSCP setup, you need to enter SQL user host from which SQL user are allowed to connect: IP of your i-MSCP server

    Please say us which value are currently set for the following parameters in your /etc/imscp/imscp.conf file:

    • DATABASE_HOST
    • DATABASE_USER_HOST

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • 1. i do this (10.1.0.2)


    << While i-MSCP setup, you need to enter SQL user host from which SQL user are allowed to connect: IP of your i-MSCP server

    2. i give them root (testet from shell with mysql -h ... -u ... -p ...)


    ther was no ask for extra host for the sql root user / or i see there not


    DATABASE_HOST = 10.1.0.2


    DATABASE_USER_HOST = 144.76.1xx.xx


    the same as BASE_SERVER_PUBLIC_IP =

  • ther was no ask for extra host for the sql root user / or i see there not

    DATABASE_HOST = 10.1.0.2


    DATABASE_USER_HOST = 144.76.1xx.xx


    the same as BASE_SERVER_PUBLIC_IP =

    i-MSCP version? You should have been asked if you use a remote SQL server.


    code.png


    So, basically, you should be asked. But I see a bug there... Validation reject private IP... I'll fix that for next release. For now, you should at least be able to set the wildcard: % even if I doubt that you want that for security reasons.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • version 1.5.3


    i do all user by hand in the database

    so it works

    in the future for the next installation yuo kill the bugs :-)

    Edited once, last by Sokoban ().

  • Sokoban


    Please, can you show us the value of the SQL_PACKAGE configuration parameter in your /etc/imscp/imscp.conf file (at bottom)?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif