At least one intermediate certificate is invalid or missing - old server & imscp working correct

  • Dear all,

    i have done a new server install with Debian 9.3 & current iMSCP stable 1.5.1, apache, php 7.1.13 php-fpm & MariaDB 10.2 - everyting worked fine and i get also everything working without any challenge.

    But now i have tried to move my first domain from old server (Debian 8, apache, Mysql 5.6, php fcgi 5.6/7.0/7.1.10 with i-MSCP 1.2.11, Build: 20160106, Codename: Andromeda) to the new one - everything no problem until i tried to add the SSL certificate in iMSCP, with the error:

    "At least one intermediate certificate is invalid or missing"

    at the old server, the same SSL certificate is working without any problem, and could be added in iMSCP admin panel for the client within a second and no error - at new server, no chance - always the error - i have copied everything 1:1 as well now also double checked with cloudflare (COMODO CA Limited certificate), where the certificate comes from - everything correct and active

    The old server is still active - when i switch the domain with the IP - everything fine - but at new server with new iMSCP 1.5.1 & Debian 9.3 - only error with adding in iMSCP admin panel

    Also when i open the Website at new server - Cloudflare shows the frontend with SSL connection - but i need for different backend tasks a "full" level - this is only possible, when i assign the certificate directly to the server, which was at old system no problem and there also still working

    I hope anybody can help - or have been there any changes at 1.5.1 regarding certificate? (admin panel for this step looks the same)

    Thank you !

    Additional information .... I got now an error message, maybe it belongs to this challenge (first time, i don't know if it is relating my probleme with the certificate):

    Version: 1.5.1
    Build: 20170908
    Nachrichtenpriorität : Error

    [IP address] Could not write in
    /var/www/imscp/gui/data/tmp/3-openssl.cnfazJJpD openssl temporary
    configuration file.

    Edited 5 times, last by Neptun ().

  • @Neptun

    Could you provide us acces to the server for investigation?


  • @Nuxwin

    Thanks for fast reply

    I will try a fresh install first, to have everything once again clean, because i have at the moment a new 2nd server to test it

    if the problems is again there, what i think - i will let you know asap

    Do you need then the IP & SSH ? - as well only of the new server or of the old too ?

  • Do you need then the IP & SSH ? - as well only of the new server or of the old too ?

    IP, SSH and an admin access to the control panel to (you can create temporary admin account). I need known the domain name for which you have the problem. For the server on which you have the problem only ;)