programme cgi dans htdocs

  • # systemctl -l status apache2.service
    ● apache2.service - LSB: Apache2 web server
    Loaded: loaded (/etc/init.d/apache2)
    Drop-In: /lib/systemd/system/apache2.service.d
    └─forking.conf
    Active: active (running) since ven. 2017-09-29 18:41:09 CEST; 30min ago
    Process: 30230 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCES S)
    Process: 27910 ExecReload=/etc/init.d/apache2 reload (code=exited, status=0/SU CCESS)
    Process: 30445 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCC ESS)
    CGroup: /system.slice/apache2.service
    ├─30460 /usr/sbin/apache2 -k start
    ├─30463 vlogger (access log
    ├─30464 /usr/sbin/apache2 -k start
    ├─30465 /usr/sbin/apache2 -k start
    └─30466 /usr/sbin/apache2 -k start



    sept. 29 18:41:07 web-8 systemd[1]: Starting LSB: Apache2 web server...
    sept. 29 18:41:09 web-8 apache2[30445]: Starting web server: apache2.
    sept. 29 18:41:09 web-8 systemd[1]: Started LSB: Apache2 web server.

  • Tout a l air de fonctionner pourtant , tu ne peut pas restart ton apache la ? Sinon donne moi l access a ton serveur via mp que j y jette un coup d oeil

    - Distribution: Debian | Release: 9.12 | Codename: stretch
    - i-MSCP Version: i-MSCP 1.5.3 | Build: 2018120800 | Codename: Ennio Morricone
    - Plugins installed: ServerDefaultPage (v. 1.3.0),Postgrey (v. 1.3.0), PolicydWeight (v. 1.3.0), ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), RoundCubePlugins (v 2.0.2), LetsEncrypt (v 3.5.0), PhpSwitcher (v 5.0.5), InstantSSH (v 5.0.1), CronJobs (v 1.4.1), PolicydSPF (v 1.2.0), Postscreen (v 1.2.0), Monitorix (v 1.2.2) & SpamAssassin (v 2.1.0)

  • si quand j'enleve
    <Directory /var/www/virtual/domain.tld/htdocs> AllowOverride AuthConfig Indexes Limit Options=Indexes,MultiViews \ Fileinfo=RewriteEngine,RewriteOptions,RewriteBase,RewriteCond,RewriteRule Nonfatal=Override DirectoryIndex index.cgi index.pl index.py index.rb Options FollowSymLinks ExecCGI AddHandler cgi-script .cgi .pl .py .rb Require all granted</Directory>je restart apache sans erreurc'est quand je l'ajoute dans fomaine.com.confque apache redemarre pas

  • Merci d'utiliser les balises pour copier ton code.

    Code
    1. <Directory /var/www/virtual/tondomain.tld/htdocs> AllowOverride AuthConfig Indexes Limit Options=Indexes,MultiViews Fileinfo=RewriteEngine,RewriteOptions,RewriteBase,RewriteCond,RewriteRule Nonfatal=Override DirectoryIndex index.cgi index.pl index.py index.rb Options FollowSymLinks ExecCGI AddHandler cgi-script .cgi .pl .py .rb Require all granted</Directory>


    puis reload apache

    Code
    1. service apache2 reload

    @Nuxwin a été on ne peut plus clair plus haut

    - Distribution: Debian | Release: 9.12 | Codename: stretch
    - i-MSCP Version: i-MSCP 1.5.3 | Build: 2018120800 | Codename: Ennio Morricone
    - Plugins installed: ServerDefaultPage (v. 1.3.0),Postgrey (v. 1.3.0), PolicydWeight (v. 1.3.0), ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), RoundCubePlugins (v 2.0.2), LetsEncrypt (v 3.5.0), PhpSwitcher (v 5.0.5), InstantSSH (v 5.0.1), CronJobs (v 1.4.1), PolicydSPF (v 1.2.0), Postscreen (v 1.2.0), Monitorix (v 1.2.2) & SpamAssassin (v 2.1.0)

  • si quand j'enleve
    <Directory /var/www/virtual/domain.tld/htdocs> AllowOverride AuthConfig Indexes Limit Options=Indexes,MultiViews \ Fileinfo=RewriteEngine,RewriteOptions,RewriteBase,RewriteCond,RewriteRule Nonfatal=Override DirectoryIndex index.cgi index.pl index.py index.rb Options FollowSymLinks ExecCGI AddHandler cgi-script .cgi .pl .py .rb Require all granted</Directory>je restart apache sans erreurc'est quand je l'ajoute dans fomaine.com.confque apache redemarre pas

    Sérieusement, faites un effort quand vous postez... Veuillez utiliser les balises bbcode.


    Aussi, veuillez nous fournir plus d'information concernant votre système:

    • Distribution, codename
    • i-MSCP version

    Reste à savoir comment vous avez ajouter les directives que je vous ai donné... Il ne suffit pas de copier bêtetement ;)


    Edit:


    @AnDee Tu as été plus rapide que moi ;)

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • désolé quand je rajoute cela mon apache repart pas

  • je reviens vers vous avec plus d'infos tout a l'heure
    désolé encore pour ces erreurs de balise
    stephan

  • @stephan


    Alors déjà, si vous avez copié sans même changer le nom de domaine dans la directive Directory, c'est que vous êtes vraiment un bon... Donnez nous accès à votre serveur svp. Cela ira beaucoup plus vite et cela nous évitera de perdre notre temps.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • il doit automatiquement y avoir quelquechose que tu as mal fait ou mal copier ou pas modifié . Je te laisse reverifié ou me laisser un access ssh en mp a ton serveur pour te confirmer ton erreur.

    - Distribution: Debian | Release: 9.12 | Codename: stretch
    - i-MSCP Version: i-MSCP 1.5.3 | Build: 2018120800 | Codename: Ennio Morricone
    - Plugins installed: ServerDefaultPage (v. 1.3.0),Postgrey (v. 1.3.0), PolicydWeight (v. 1.3.0), ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), RoundCubePlugins (v 2.0.2), LetsEncrypt (v 3.5.0), PhpSwitcher (v 5.0.5), InstantSSH (v 5.0.1), CronJobs (v 1.4.1), PolicydSPF (v 1.2.0), Postscreen (v 1.2.0), Monitorix (v 1.2.2) & SpamAssassin (v 2.1.0)

  • non pas stupide a ce point :) j'ai bien modifié dans la directive : Directory
    suis sous debian jessie
    i-mscp 1.5.1
    plugin installed : instantssh, letsencrypts