No domain reachable after upgrade to 1.4.3

  • Ok, sorry for my incomplete information before.

    apache is running, imscp_panel.log is empty. Trying to activate a plugin I get "an unexpected error occurred"

    The Server is driven by Ubuntu 16.04 Xenial Xerus,
    PHP is
    # php -version
    PHP (cli) (built: Apr 11 2017 14:36:44) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies with Zend OPcache, Copyright (c) 1999-2017, by Zend Technologies
    IMSCP Version is 1.4.3 now:
    i-MSCP 1.4.3
    Build: 20170417
    Codename: Zimmer
    Browser is Firefox 45.8.0
    I'm using MariaDB

    The exact steps to reproduce the problem:

    About two weeks ago: New setup of the server from a clean install with Ubuntu 16.04, updating the sources and upgrading the installed distribution, setting up new, clean imscp 1.4.2 (no backups used), added plugins and set up one domain. Worked like a charm, no problems so far.

    Problem occurred today: setting up a new domain, no errors, but not reachable. The nameserver points to the right IP, but it is not found on the Host.

    Steps today:
    Tried to upgrade from i-mscp 1.4.2 to 1.4.3 following the advice, first
    to update repositories, then upgrade dist, and then upgrade i-mscp.
    Errors concerning imscp showed up, but upgrading i-mscp to 1.4.3
    performed without any error. apt-get update && apt-get
    dist-upgrade afterwards also.

    Problem: no domain is reachable, only the control-panel is reachable. Now I see that there is a new problem with the Postgrey-Plugin, which didn't show up before, but which is not the deal here.


    • setup4.png

      (244.57 kB, downloaded 12 times, last: )
  • @symphosius

    Can we access to your server?


  • @symphosius

    Got it.

    I need also panel admin password. Note that I'll eat first.
    Please don't do anything more on the server.
    I stay you informed.


  • @symphosius

    • Upgrade to version 1.4.3 was not finished properly FIXED
    • The IP set for the domain was wrong. Tthe IP set for the customer must be the one used for the DNS A record. FIXED
    • You have installed phpmyadmin and roundcube distribution packages which are not needed (i-MSCP provide newest versions of them). FIXED
    • Plugin directory was empty NOT FIXED, SEE BELOW

    Regarding the error you have reported: It seem that you have a backup of your old /var/www directory into the /var/www-backup directory ... I think that you have moved your /var/www directory in the /var/www-backup directory before upgrading i-MSCP which could explain why the plugins were not found during upgrade, hence the error... You should think a bit more before acting ;)

    What now?

    • You must restore your sites data
    • You must reinstall your plugins

    Thread closed.