Posts by Mr.X

    Salut Nuxwin,

    This issue has been fixed lately in our git repository...

    I cloned from git today on the 1.5.3-maintenance branch and still see this error.


    Br

    Mr.X

    Just testing out Debian 10 support and noticed when attempting to install any plugin i get the following error


    Code
    1. An unexpected error occurred
    2. An exception has been thrown in file /var/www/imscp/gui/src/Plugin/Validate/PluginArchive.php at line 251:
    3. Argument 1 passed to iMSCP\Plugin\Validate\PluginArchive::_getPluginInfoFromString() must be of the type string, null given, called in /var/www/imscp/gui/src/Plugin/Validate/PluginArchive.php on line 442

    I know it's not production ready, just thought I would add this to this thread.

    Hi,


    any news on this issue? Looks like i-mscp is expecting a type of string instead of null. Something we can fix? This is blocking me from testing the plugins with the latest version.


    Br

    Mr.X

    Hi FloRet88,


    thanks for your quick reply. I know I am not on the latest version but will update in the next days.

    Meanwhile I fixed the issue by executing

    Code
    1. 1. apt install python-certbot-apache
    2. 2. certbot renew

    and renew in the GUI at the end.


    BR

    Mr.X

    Hi,


    since today we see this error message in the GUI. Anyone else with the same issue and a solution available?



    Quote

    Traceback (most recent call last):
    File "/usr/local/sbin/certbot", line 7, in <module>
    from certbot.main import main
    File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/main.py", line 5, in <module>
    import logging.handlers
    File "/usr/lib/python2.7/logging/__init__.py", line 26, in <module> import sys, os, time, cStringIO, traceback, warnings, weakref, collections

    File "/usr/lib/python2.7/weakref.py", line 14, in <module> from _weakref import ( ImportError: cannot import name _remove_dead_weakref at /var/www/imscp/gui/plugins/LetsEncrypt/backend/LetsEncrypt.pm line 834.

    Running with version

    Quote


    i-MSCP 1.5.3

    Build: 20180516

    Codename: Ennio Morricone


    Br

    Mr.X

    In our wiki, we don't mention that Buster is supported, and if you look at the INSTALL.md file of the latest stable version, you can see that the list of supported Debian versions are Debian Jessie (7.x) and Debian Stretch (8.x). See https://github.com/i-MSCP/imsc…supported-debian-versions


    So, basically put, you're using an i-MSCP version, and a PhpSwitcher plugin version that were not tested under Debian Buster. Current i-MSCP stable version is compatible with Debian Stretch, not with Debian Buster. Therefore, I'm primarly wondering why you did that update without more thinking about your current environment... Debian Buster has just been released.


    Regarding the configuration failure when you try to re-compile your PHP versions, this can be due to many things... I cannot say more without investigating directly on your server.

    Salut Nuxwin,


    thanks for your reply. The update was not on purpose, apt was using stable .-/

    Any change to get a beta of phpSwitch? Or a possible release date?

    I could see in one of the git commits that apc makes some troubles ...


    Br

    Jan

    Debian 10 isn't supported officially (but another user reported its working). I think thats the issue here at the moment.

    The needed phpswitcher version will re released with or close after / before the new i-MSCP version. Which got support for newer php versions.

    Hi Iceman,


    thanks for your reply. I've read the wiki and checked the forum before. But couldn't find something similar to this.

    Do we know when the new version will be released... yeah, I know when it's done it's done .-) But will it be 2 months or 6 months?


    I don't know why your text about wiki and forum is not shown here in the forum while it's in your email. Nevertheless ...

    Hi all,

    last night one of my servers updated to the lastest stable version. All looked good at first. This morning a customer called us that his webpage is not working anymore.

    After some investigation I found out that the php version / PhpSwitcher is not working anymore .-(

    System is running latest Debian Buster and imscp 1.5.3.


    In the apache log I could see

    Quote


    [Mon Jul 15 10:14:04.694796 2019] [proxy:error] [pid 22367:tid 140344532383488] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /run/phpswitcher/psw7.0-fpm-DOMAIN.sock (DOMAIN) failed

    .5

    I checked the admin gui and could see also error messages here like


    Quote

    Plugin::PhpSwitcher::_checkPhpVersionData: `/opt/phpswitcher/20180618/php7.0/bin/php-cgi' doesn't looks like a PHP FastCGI binary

    so I tried to reinstall different php version via

    Quote

    perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl --auto-setup 5.6


    but I received this error message

    Quote

    [ERROR] main: An unexpected error occurred: An error occurred while executing the install MAKE(1) target for php-5.6.32: aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'

    ../configure: line 5408: test: too many arguments

    configure: error: freetype-config not found.


    make: *** [/var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/Makefile:370: configure-5.6-stamp] Error 1

    same error message for 7.1

    Quote

    [ERROR] main: An unexpected error occurred: An error occurred while executing the install MAKE(1) target for php-7.1.11: aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'

    ../configure: line 5352: test: too many arguments

    configure: error: freetype-config not found.

    make: *** [/var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/Makefile:370: configure-7.1-stamp] Error 1

    but freetype fonts are installed

    Quote

    dpkg -l|grep freetype

    ii libfreetype6:amd64 2.9.1-3 amd64 FreeType 2 font engine, shared library files

    ii libfreetype6-dev:amd64 2.9.1-3 amd64 FreeType 2 font engine, development files

    Right now I don't know how to solve this issue. Do you have a hint for me? Merci !


    BR

    Mr.X