Problem with dovecot in imscp

  • I tried a migration form courier to dovecot, migration works fine, but, when mail arrive and procesed i have a error with perms in dovecot.

    Platform: Ubuntu Server 10.04



    Oct 29 19:29:30 leia postfix/pipe[6602]: 511C513BD3: to=<>, relay=dovecot, delay=2.6, delays=2.5/0.04/0/0.04, dsn=4.3.0, status=deferred (temporary failure. Command output: Fatal: open(/etc/dovecot/dovecot.conf) failed: Permission denied )

    I checked perms and seems fine. dovecot.conf is owned by root and have read permisions. I find several articles in google and try all sugestions that i can found, by without lucky, error still remain.

    Set all pems (777) to dovecot.conf dont work, error still happend.

    I tried migration twice and got same result in both tries. So, i'm stuck in this point and have no idea why i have this issue.

    Any idea.? Ty


  • Test rights for /etc (root:root 0755), and /etc/dovecot (root:root 0755)

  • Test rights for /etc (root:root 0755), and /etc/dovecot (root:root 0755)


    I run a new migration proccess and set rights 0755 for etc and etc/dovecot. Then, i run test sending mails from diferents servers and no error.

    Thanks very much!