Bind default records for all domains - DMARC ressource record in db.tpl

  • Hello,

    i'm using i-MSCP (1.5.3) on Debian Stretch. Everything is working fine so far :)

    Now i am trying to set default DMARC records for all domains on i-MSCP. I already managed to set default mx, and spf records by editing the db.tpl file that i-MSCP uses to generate the zone files. I tried using the same way to define a default DMARC record for all my domains. But as the i-MSCP parser replaces all @ with the domain name, the @ in the email within the value of the DMARC record also gets replaced. 19 is the critical line in the following code.

    The following line is copied from the file that i-MSCP generates for bind. As you can see @ within the postmaster email is replaced by

    Code: /etc/imscp/bind/working/
    1. IN TXT "v=DMARC1; p=none; sp=none; fo=; ri=3600;;"

    I already tried to escape the @ by a backslash and also tried two @@ but nothing worked. Is there a way to escape the @ or do you have another idea to solve the problem?

    Thanks a lot in advance :)