Plugin-Installation after update hanging - need to unclutter MySQL DB -

  • Hi I have a "solved" problem - but embarrassingly I fail to repeat that solution.

    I upgraded from 1.5.1 to 1.5.3 and I tried to install the SpamAssassin plugin again. I managed to reproduce the error message

    "Plugin::SpamAssassin::_setSpamassassinUserprefs: Error while executing statement: Duplicate entry '$GLOBAL-use_pyzor-1' for key 'user_pref" The solution is described in

    Plugin-Installation nach Server-Migration

    i-MSCP is up an running - no problems.

    I am an absolutely novice on MySQL.

    My question to the audience.

    How do I open a SQL shell (with user passwd db ... - see below ) to resolve that problem?

    So fare I got to

    # mysql -udebian-sys-maint -p verysecretpass

    give me shell but that does not help me a lot.

    I have the output of

    grep DATABASE_PORT /etc/imscp/imscp.conf

    grep DATABASE_PASSWORD /etc/imscp/imscp.conf

    grep DATABASE_HOST /etc/imscp/imscp.conf

    grep DATABASE_NAME /etc/imscp/imscp.conf

    Maybe the solution is a lot more simple....