PhpMyAdmin Auto Login not working

  • Hello,

    Using i-MSCP 1.2.17
    Build: 20160312

    I cannot login using phpmyadmin autologin from admin panel.
    Credits are OK, I can login without problem using /pma URL, but when I click on "phpmyadmin" button, I get this error message: "An error occurred during authentication."

    Which logs should I check to resolve this ? Thanks, Claude.

  • Fastest solution is to reinstall panel using imscp-autoinstall for regenerating pma key, or syncronyse imscp.conf with pma config file by hands (better - first) :D

  • Hi DragonZX, thanks for your answer.

    I cannot use imscp-autoinstall, so I need to use your second option.
    I cannot find anything to synchronise in /etc/imscp/imscp.conf. The only password related to mysql I found is the root password, which I think is not what i'm looking for.
    Is this bug related to $cfg['Servers'][$i]['controluser'] = 'pma_user'; and password ?

    could you please be a little more precise about how I should synchronise those files ? Thanks a lot for your help.

  • No, as I understand you, it used cookie autorisaton in your example, so blowfish_secret value must be the same in /var/www/imscp/gui/tools/pma and /etc/imscp/pma/working directories (, but not shure, reinstall is better.