Posts by sfsolutions

    i see the similar issue.

    I use L§ plugin 3.4 with i-mscp 1.5.3 on Ubuntu 14.04.05 LTS


    I get a Fake LE intermediate X1


    this is from the logfile:


    any ideas what to change ?


    Best wishes


    Niels

    Hi,


    I am a bit confused. Which is the favourite i-mscp implementation for PHP:


    PHP-FPM or fcgi ?


    Two aspects:
    1) performance
    2) Adjustability of php settings I remember that one is more flexible and the settings like fopen can be set in the i-mscp gui.
    THX and best wishes


    Niels

    Hello,


    on an i-mscp server 1.5.1 with el plugin 3.30 for some domains i get this error


    Challenge failed for domain xxx.de
    Challenge failed for domain xxx.de
    Challenges failed for all domains


    When i try to do an update with certbot i get:


    Shell-Script
    1. -------------------------------------------------------------------------------You have an existing certificate that contains a portion of the domains yourequested (ref: /etc/letsencrypt/renewal/www.xxx.de.conf)It contains these names: www.xxx.deYou requested these names for the new certificate: xxxx.de,www.xxxx.de.Do you want to expand and replace this existing certificate with the newcertificate?-------------------------------------------------------------------------------(E)xpand/(C)ancel: ERenewing an existing certificatePerforming the following challenges:tls-sni-01 challenge for xxx.detls-sni-01 challenge for www.xxx.deWaiting for verification...Cleaning up challengesCannot find a cert or key directive in /files/etc/apache2/sites-available/xxx.de_ssl.conf/VirtualHost. VirtualHost was not modifiedUnable to find cert and/or key directivesIMPORTANT NOTES: - Unable to install the certificate - Congratulations! Your certificate and chain have been saved at /etc/letsencrypt/live/www.xxx.de/fullchain.pem. Your cert will expire on 2018-08-01. To obtain a new or tweaked version of this certificate in the future, simply run certbot again with the "certonly" option. To non-interactively renew *all* of your certificates, run "certbot renew"root@ispcp:~#


    I also cannot delete it in frontend and set new because the buttons disappear


    Any idea what to do ?


    Many thanks and best wishes


    Niels


    P.S. When i do the certbot i also see these errors:


    This might not work.Attempting to parse the version 0.23.0 renewal configuration file found at /etc/letsencrypt/renewal/xxx.conf with version 0.15.0 of Certbot. This might not work.Attempting to parse the version 0.21.1 renewal configuration file found at /etc/letsencrypt/renewal/xyyy.conf with version 0.15.0 of Certbot. This might not work.Attempting to parse the version 0.23.0 renewal configuration file found at /etc/letsencrypt/renewal/aaaa.de.conf with version 0.15.0 of Certbot. This might not work.Attempting to parse the version 0.21.1 renewal configuration file found at /etc/letsencrypt/renewal/888.de.conf with version 0.15.0 of Certbot. This might not work.Attempting to parse the version 0.23.0 renewal configuration file found at /etc/letsencrypt/renewal/jjj.de.conf with version 0.15.0 of Certbot. This might not work.Attempting to parse the version 0.21.1 renewal configuration file found at /etc/letsencrypt/renewal/888.com.conf with version 0.15.0 of Certbot. This might not work.Attempting to parse the version 0.21.1 renewal configuration file found at /etc/letsencrypt/renewal/kkk.conf with version 0.15.0 of Certbot. This might not work.

    Hello,


    for one cert we have an error:


    An unexpected error occurred:
    MissingNonce: Server POST response did not include a replay nonce, headers: {'Content-Length': '274', 'Expires': 'Sun, 17 Dec 2017 23:00:38 GMT', 'Server': 'AkamaiGHost', 'Connection': 'close', 'Pragma': 'no-cache', 'Cache-Control': 'max-age=0, no-cache, no-store', 'Date': 'Sun, 17 Dec 2017 23:00:38 GMT', 'Content-Type': 'text/html', 'Mime-Version': '1.0'} (This may be a service outage)
    Please see the logfiles in /var/log/letsencrypt for more details.


    How can i try to renew this cert ?


    THX and best wishes


    Niels


    Ubuntu 14.04.05, i-MSCP 1.4.4, LE 3.3.0

    Hello,


    i recover ATM a server it is ubuntu 14.04.05 ... old server was broken so i setup a new one with same ubuntu.


    I use i-mscp 1.4.4 (like it was before)


    now when i run the installer i get an error.


    [ERROR] │ │ │ │ Error while performing step: │ │ │ │ Executing Package::FrontEnd install tasks... │ │ │ │ Error was: │ │ │ │ An unexpected error occurred... │ │ │ │ Please have a look at http://i-mscp.net/forum if you need help.


    and this is in log file:


    Code
    1. Module ssl already enabled[Sat Mar 10 00:06:05 2018] [debug] iMSCP::Execute::execute: a2ensite 00_nameserver.conf[Sat Mar 10 00:06:05 2018] [debug] Servers::httpd::apache_php_fpm::enableSites: Site 00_nameserver already enabled[Sat Mar 10 00:06:05 2018] [debug] iMSCP::Execute::execute: a2enconf 00_imscp.conf[Sat Mar 10 00:06:05 2018] [debug] Servers::httpd::apache_php_fpm::enableConfs: Conf 00_imscp already enabled[Sat Mar 10 00:06:05 2018] [debug] iMSCP::Execute::execute: a2disconf php5.6-cgi.conf[Sat Mar 10 00:06:05 2018] [debug] Servers::httpd::apache_php_fpm::disableConfs: Conf php5.6-cgi already disabled[Sat Mar 10 00:06:05 2018] [debug] iMSCP::Execute::execute: a2disconf php5.6-fpm.conf[Sat Mar 10 00:06:05 2018] [debug] Servers::httpd::apache_php_fpm::disableConfs: Conf php5.6-fpm already disabled[Sat Mar 10 00:06:05 2018] [debug] iMSCP::Execute::execute: a2disconf serve-cgi-bin.conf[Sat Mar 10 00:06:05 2018] [debug] Servers::httpd::apache_php_fpm::disableConfs: Conf serve-cgi-bin already disabled[Sat Mar 10 00:06:05 2018] [debug] iMSCP::Execute::execute: a2dissite 000-default.conf[Sat Mar 10 00:06:05 2018] [debug] Servers::httpd::apache_php_fpm::disableSites: Site 000-default already disabled[Sat Mar 10 00:06:05 2018] [debug] iMSCP::Execute::execute: a2dissite default-ssl.conf[Sat Mar 10 00:06:06 2018] [debug] Servers::httpd::apache_php_fpm::disableSites: Site default-ssl already disabled[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering beforeHttpdBuildConfFile event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering afterHttpdBuildConf event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering afterHttpdBuildConfFile event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering beforeHttpdBuildConfFile event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering afterHttpdBuildConf event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering afterHttpdBuildConfFile event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering beforeHttpdBuildConfFile event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering afterHttpdBuildConf event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering afterHttpdBuildConfFile event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: rm -f /var/www/virtual/*/logs/*.log[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: postconf -d -h mail_version[Sat Mar 10 00:06:06 2018] [debug] Servers::mta::postfix::installer::setVersion: 2.11.0[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering beforeMtaBuildMasterCfFile event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering beforeMtaBuildMainCfFile event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::EventManager::trigger: Triggering afterMtaBuildConf event[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::executeNoWait: postconf -c /etc/postfix smtpd_sasl_authenticated_header smtpd_recipient_restrictions broken_sasl_auth_clients smtpd_sasl_path dovecot_destination_concurrency_limit smtpd_sender_restrictions smtpd_helo_restrictions smtpd_sasl_security_options smtpd_sasl_type smtpd_sasl_auth_enable virtual_transport dovecot_destination_recipient_limit[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: postconf -e -c /etc/postfix smtpd_sasl_authenticated_header=yes smtpd_recipient_restrictions=reject_non_fqdn_recipient, reject_unknown_recipient_domain, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_unlisted_recipient, permit broken_sasl_auth_clients=yes smtpd_sasl_path=private/auth dovecot_destination_concurrency_limit=2 smtpd_sender_restrictions=permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_sender, reject_unknown_sender_domain, permit smtpd_helo_restrictions=permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname, permit smtpd_sasl_security_options=noanonymous smtpd_sasl_type=dovecot smtpd_sasl_auth_enable=yes virtual_transport=dovecot dovecot_destination_recipient_limit=1[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: newaliases[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: named -v[Sat Mar 10 00:06:06 2018] [debug] Servers::named::bind::installer::_getVersion: BIND 9.9.5-3ubuntu0.17-Ubuntu (Extended Support Version)[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: resolvconf -d lo.imscp[Sat Mar 10 00:06:06 2018] [debug] Servers::po::dovecot::installer::_setupSqlUser: Creating dovecot_user@localhost SQL user[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: nginx -v[Sat Mar 10 00:06:06 2018] [debug] Package::FrontEnd::Installer::_setHttpdVersion: Nginx version set to: 1.4.6[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: pkill -KILL -u imscp ; usermod -c 'i-MSCP Master Web User' -d '/var/www/imscp/gui' -l vu2000 -m vu2000[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::getExitCode: Command exited with value: 6[Sat Mar 10 00:06:06 2018] [debug] Package::FrontEnd::Installer::_addMasterWebUser: usermod: user 'vu2000' does not exist[Sat Mar 10 00:06:06 2018] [debug] iMSCP::Execute::execute: /usr/bin/dialog --no-shadow --cancel-label Back --backtitle 'i-MSCP - internet Multi Server Control Panel (1.4.4)' --help-label Help --colors --ok-label Ok --yes-label Yes --no-label No --title 'i-MSCP Installer Dialog' --exit-label Abort --msgbox '\Z1[ERROR]\ZnError while performing step:Executing Package::FrontEnd install tasks...Error was:\Z1An unexpected error occurred...\ZnPlease have a look at http://i-mscp.net/forum if you need help.' 48 125 [Sat Mar 10 00:06:07 2018] [debug] iMSCP::Execute::execute: /usr/bin/dialog --no-shadow --cancel-label Back --backtitle 'i-MSCP - internet Multi Server Control Panel (1.4.4)' --help-label Help --colors --ok-label Ok --yes-label Yes --no-label No --title 'i-MSCP Installer Dialog' --exit-label Abort --msgbox '\Z1[ERROR]\ZnError while performing step:Processing servers/packagesError was:\Z1An unexpected error occurred...\ZnPlease have a look at http://i-mscp.net/forum if you need help.' 48 125 [Sat Mar 10 00:06:08 2018] [debug] iMSCP::Execute::execute: /usr/bin/dialog --no-shadow --cancel-label Back --backtitle 'i-MSCP - internet Multi Server Control Panel (1.4.4)' --help-label Help --colors --ok-label Ok --yes-label Yes --no-label No --title 'i-MSCP Installer Dialog' --exit-label Abort --msgbox '\Z1[ERROR]\ZnError while performing step:Processing setup tasksError was:\Z1An unexpected error occurred...\ZnPlease have a look at http://i-mscp.net/forum if you need help.' 48 125 [Sat Mar 10 00:06:09 2018] [error] autoinstaller::Functions::install: An error occurred while performing installation steps[Sat Mar 10 00:06:09 2018] [debug] iMSCP::Bootstrapper::unlock: Releasing exclusive lock on /tmp/imscp-disable-accounts.lock[Sat Mar 10 00:06:09 2018] [debug] iMSCP::Bootstrapper::unlock: Releasing exclusive lock on /tmp/imscp.lock[Sat Mar 10 00:06:09 2018] [debug] iMSCP::Bootstrapper::unlock: Releasing exclusive lock on /tmp/imscp-backup-all.lock[Sat Mar 10 00:06:09 2018] [debug] iMSCP::Bootstrapper::unlock: Releasing exclusive lock on /tmp/imscp-backup-imscp.lock[Sat Mar 10 00:06:09 2018] [debug] iMSCP::Bootstrapper::unlock: Releasing exclusive lock on /tmp/imscp-srv-traff.lock[Sat Mar 10 00:06:09 2018] [debug] iMSCP::Bootstrapper::unlock: Releasing exclusive lock on /tmp/imscp-vrl-traff.lock[Sat Mar 10 00:06:09 2018] [debug] iMSCP::Bootstrapper::unlock: Releasing exclusive lock on /tmp/awstats_updateall.pl.lock[Sat Mar 10 00:06:09 2018] [debug] iMSCP::Bootstrapper::unlock: Releasing exclusive lock on /tmp/imscp-dsk-quota.lockroot@cp:/home/eegadmin/imscp-1.4.4#


    when i start nginx i get this:
    And this what i find in apache error_log

    Code
    1. [Fri Mar 09 23:50:27.524849 2018] [core:notice] [pid 8526:tid 140039053940608] AH00094: Command line: '/usr/sbin/apache2'[Fri Mar 9 23:50:27 2018] [notice] vlogger: DBI usage tracker dump interval set to 30 seconds[Fri Mar 9 23:50:27 2018] [notice] vlogger: started CustomLog Handler -- resuming normal operations[Fri Mar 09 23:55:44.424871 2018] [mpm_event:notice] [pid 8526:tid 140039053940608] AH00491: caught SIGTERM, shutting down[Fri Mar 9 23:55:44 2018] [notice] vlogger: caught TERM, shutting down[Fri Mar 09 23:56:10.632286 2018] [suexec:notice] [pid 1095:tid 140146509555584] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)[Fri Mar 09 23:56:10.694267 2018] [mpm_event:notice] [pid 1115:tid 140146509555584] AH00489: Apache/2.4.10 (Ubuntu) OpenSSL/1.0.1f configured -- resuming normal operations[Fri Mar 09 23:56:10.694312 2018] [core:notice] [pid 1115:tid 140146509555584] AH00094: Command line: '/usr/sbin/apache2'[Fri Mar 9 23:56:11 2018] [alert] vlogger: couldn't connect to SQL server: DBI connect('database=imscp;host=127.0.0.1;port=3306','vlogger_user',...) failed: Can't connect to MySQL server on '127.0.0.1' (111) at /usr/local/sbin/vlogger line 279.[Fri Mar 9 23:56:11 2018] [notice] vlogger: DBI usage tracker feature turned off[Fri Mar 9 23:56:11 2018] [notice] vlogger: started CustomLog Handler -- resuming normal operations[Fri Mar 09 23:58:22.908803 2018] [mpm_event:notice] [pid 1115:tid 140146509555584] AH00491: caught SIGTERM, shutting down[Fri Mar 9 23:58:22 2018] [notice] vlogger: caught TERM, shutting down[Sat Mar 10 00:10:43.040346 2018] [suexec:notice] [pid 5156:tid 140037820184448] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)[Sat Mar 10 00:10:43.075916 2018] [mpm_event:notice] [pid 5158:tid 140037820184448] AH00489: Apache/2.4.10 (Ubuntu) OpenSSL/1.0.1f configured -- resuming normal operations[Sat Mar 10 00:10:43.075962 2018] [core:notice] [pid 5158:tid 140037820184448] AH00094: Command line: '/usr/sbin/apache2'[Sat Mar 10 00:10:43 2018] [notice] vlogger: DBI usage tracker dump interval set to 30 seconds[Sat Mar 10 00:10:43 2018] [notice] vlogger: started CustomLog Handler -- resuming normal operations[Sat Mar 10 00:10:43 2018] [notice] vlogger: DBI usage tracker dump interval set to 30 seconds[Sat Mar 10 00:10:43 2018] [notice] vlogger: started CustomLog Handler -- resuming normal operations[Sat Mar 10 00:13:50.356934 2018] [mpm_event:notice] [pid 5158:tid 140037820184448] AH00491: caught SIGTERM, shutting down[Sat Mar 10 00:13:50 2018] [notice] vlogger: caught TERM, shutting down


    Code
    1. x:/run/imscp/imscp_panel.sock:", host: "cp.everenergy.de:8080"
    2. 2018/03/09 23:57:29 [crit] 1327#0: *3 connect() to unix:/run/imscp/imscp_panel.sock failed (2: No such file or directory) while connecting to upstream, client: 195.226.173.228, server: cp.everenergy.de, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/run/imscp/imscp_panel.sock:", host: "cp.everenergy.de:8080"
    3. 2018/03/09 23:58:14 [crit] 1327#0: *5 connect() to unix:/run/imscp/imscp_panel.sock failed (2: No such file or directory) while connecting to upstream, client: 195.226.173.228, server: cp.everenergy.de, request: "GET /wp-login.php HTTP/1.1", upstream: "fastcgi://unix:/run/imscp/imscp_panel.sock:", host: "cp.everenergy.de:8080", referrer: "http://jobchance.info/wp-login.php"
    4. 2018/03/09 23:58:14 [crit] 1327#0: *5 connect() to unix:/run/imscp/imscp_panel.sock failed (2: No such file or directory) while connecting to upstream, client: 195.226.173.228, server: cp.everenergy.de, request: "GET /wp-login.php HTTP/1.1", upstream: "fastcgi://unix:/run/imscp/imscp_panel.sock:", host: "cp.everenergy.de:8080", referrer: "http://jobchance.info/wp-login.php"

    any help a lot appreciated how to tale the next step to get all runnning again