Posts by coolternet

    When i've tryed to upgrade from 5.3-1.5.3-20180516 to 1.5.3-2018120800, i'm getting an error during the process

    Quote

    [ERROR] iMSCP::Composer::_getComposer: Couldn't get composer.phar version at /usr/local/src/i-MSCP-imscp-19f9902/engine/PerlLib/iMSCP/Composer.pm line 203.


    [ERROR] autoinstaller::Functions::install: An error occurred while performing installation steps

    I found several post on this forum but nothing about a good solution. I've tryed the solution with

    setfacl -Rb /var

    and

    setfacl -Rb /

    But i receive "Command not found"

    If anyone can give me a bit help

    best regards:*


    UPDATE : Une solution a été trouvé qui a fonctionné pour moi, c'est de vider le contenu du dossier /var/local/imscp et ensuite, refaire la mise à jour.

    Debian 9

    En fait, OVH n'ont rien modifié. J'ai testé sur une VM local et j'avais le même problème. C'est IMSCP qui a changé un truc.

    Chaque fois que j'essais d'installer i-mscp, j'ai toujours ce problème à la fin de l'installation

    PHP modules are not installed or not enabled: apc, apcu


    J'ai installé la version 1.5.3 dès sa sortie, mais je n'avais pas eu ce soucis.

    Une personne aurait une ligne de commande pour corriger ça ?
    J'ai tenté avec le tuto ici : How to Install the PHP APCu Extension - ServerPilot mais sans succès.

    Si une personne à une idée ce serait apprécié.:angel:

    UPDATE : Pour ceux et celles qui ont se problème, j'ai tapé apt install php7.1-apc* et ça aura fixé tout mes soucis.

    Linux Debian 9

    OS : Debian 9

    I-Mscp Version : 1.5.3
    I-Mscp Build : 2018120800


    Bonjour, je viens de me procurer Let's Encrypt version 3.5.0, et j'ai un petit soucis d'installation. En faite, ce soucis s'étend à plusieurs plugins.

    Lorsque je clique sur le bouton "Install Plugin" (+), j'ai le message qui indique que l'installation est planifier, ensuite je recharge la page, et je perçois le message d'erreur suivant : Unexpected error
    En cliquant sur le petit bouton (?)
    , j'ai ce message :

    Code
    1. An unexpected error occurred:
    2. Plugin::LetsEncrypt::install: E: Sub-process /usr/bin/dpkg returned an error code (1) at /var/www/imscp/gui/plugins/LetsEncrypt/backend/LetsEncrypt.pm line 478.

    J'ai vu sur de differents post une commande à exécuter qui aurait pour objectif de corriger un possible soucis de dépendance :

    Code
    1. apt-get --no-install-recommends install ca-certificates libarray-diff-perl libconvert-asn1-perl libdatetime-format-strptime-perl lsb-release

    Et donc, voici ce que j'ai obtenu suite à cette ligne de commande

    Je ne comprend pas pourquoi je ne vois rien de Let's Encrypt, mais une chose est certaine, c'est que SpamAssassin est problématique dans mon cas.

    Bonjour à tous. Je rammene un problème très récurent pour certains.

    Pour faire cours, j'ai tenté par plusieurs moyen de modifier mon "upload_max_filesize" que ce soit par le panel ou en éditant tout les fichier relié au domaine et php.


    Voici ce que j'utilise :

    I-MSCP 1.5.3

    PhP 7.1 FPM
    Google Chrome 67

    Aucun plugin


    Les changements ne sont pas pris en compte par le panel i-mscp même après redémarrage du serveur web et serveur machine.

    Aucun log ne recense le problème.


    :dodgy:


    J'ai vu sur un autre post de tenter de modifier les params par l'administration pour le revendeur et ensuite le revendeur du client mais, les params ne sont pas changeable.


    J'aimerais savoir si une personne a réussi à faire ce changement.
    À noter que j'utilisais la version précédente et j'avais réussi mais je n'y parvient pas avec cella.

    Bonjour à tous.


    J'utilise :
    I-MSCP : version 1.5.1 build: 20170908
    PhP : 7.1.11
    OS : Debian 9.2


    Un de mes clients m'a envoyé un ticket par le panel. Je vois l'alerte " You have a new support ticket. " mais lorsque je clique sur "Support", ça rammene vers : /reseller/index.php
    Es-ce qu'une autre personne a eu ce genre de trouble la ? :angel:

    Effectivement. Iptables.
    En gros, ce que je fesais c'est d'ouvrir tout les ports necessaire pour le fonctionnement de IMSCP (ceux que imscp allow) et je fermais le restant. Le problème c'est que INPUT DROP bloque tout les port de IMSCP également donc j'aai créé une rules qui est indépendante de IMSCP pour permettre l'ouverture des port. Suite à notre conversation en privé, j'ai fais un test " reset all rules iptables " -> INPUT ACCEPT / OUTPUT ACCEPT et tout fonctionne comme si rien étaient. Donc, mon problème depuis 1.4.x serait du à Iptables mal configuré. @Nuxwin, tu peux supprimer les post d'aide qui s'avère inutile visiblement. Je vais donc continuer mes fameux test avec iptables pour tenter de comprendre la raison du " pourquoi tout se bloque quand je INPUT DROP alors que imscp les accept " :)