Posts by BeNe

    @Nuxwin


    Big Thanks for your time and investigation!
    Just for my understanding:


    We need the MySQL client library only to build PHP 4.4, 5.2 since for the others version (5.3, 5.4, 5.5, 5.6, 7.0, 7.1), we use the native MySQL driver (mysqlnd) that is bundle with those PHP versions...

    So if i _only_ need PHP Version 5.3 or higher i don´t need to install "libmariadbclient-dev" because we use the native MySQL driver (mysqlnd) that is bundled with those PHP versions ?
    Mean´s - i can remove the "libmariadbclient-dev" from the php_compiler.pl dependencies list and start to compile ? Just as a fast workaround.


    Thanks!

    Habe das Thema als Erledigt markiert.
    Warst dann schneller als ich mit dem Ban der IP´s ;) Ja, gerne kein Problem.


    Noch ein Tipp am Rande:
    Wenn Du eh schon selber mit Proxmox eine Virtualisierung am laufen hast, bau Dir eine Firewall auf und setzte diese vor deine Webserver.
    Kannst z.B. pfSense oder den fork OPNsense nehmen. Ist beiden OpenSource und kommt mit viele Funktionen. Snort und Suricata würde bei solchen Sachen helfen und blocken.
    Alternative ist noch Fail2ban.


    Greez

    Das sollte schon passen. Hast Du was in den Logs gefunden oder die Verbindungen überprüft ?
    Vielleicht siehst Du über den Apache Server Status mehr ?


    Prüfe mal ob das Modul aktiv ist

    Shell-Script
    1. apache2ctl -M | grep status

    Wenn nicht aktiviere es.


    Wenn dass passt nimm am besten einen browser für die shell wie lynx oder w3m und rufe die server-status Seite auf:


    Shell-Script
    1. w3m localhost/server-status

    Damit siehst Du alle Anfragen mit URL bzw. der Anfrage. Da sollte es sehr schnell auffallen wer die Threads aufbraucht.


    // EDIT


    Ja, nach deinem letzten Screenshot gehen wohl sehr viele Anfragen auf deinen Server ein. Am besten blockst Du die IP´s.

    OK! Hast Du einen vServer oder eine Hardware Maschine ?
    Bei den meisten vServern gibt es ein Maximum für alles mögliche (Verbindungen, geöffnete Dateien usw.)
    Wobei ich erstmal nicht denke das es daran liegt. Bei 1000 Workers benötigst Du auch mehr RAM. Was hat dein Server an Arbeitsspeicher ?
    Wieviele Domains laufen den auf deinem Server ?


    Denke mal fast das ein Script oder sonstige Anfragen (woher auch immer) am Apache ankommen und die Worker auslasten - so das für die kommenden nichts mehr geht.
    Am besten nochmals die Kunden Apache Logs prüfen ob Du was dazu finden kannst. Würde es mit apachetop, netstat usw. versuchen

    Hello,


    i updated my Debian Jessie Server to the current Stretch Version and then to the latest i-MSCP Version (as described here in the forum). Everything went well and works.
    But i have some problems with the PhpSwitcher Plugin and the need Packages. Because i selected MariaDB 10.2 during the setup and not the default 10.1 for Debian Stretch.


    Here are some infos about the system:


    i-MSCP Infos

    Shell-Script
    1. ## i-MSCP version infoBuildDate = 20170710Version = 1.4.7CodeName = ZimmerPluginApi = 1.4.1# Distro infoDISTRO_ID = debianDISTRO_CODENAME = stretchDISTRO_RELEASE = 9.0FRONTEND_SERVER = nginxFTPD_SERVER = proftpdHTTPD_SERVER = apache_php_fpmMTA_SERVER = postfixNAMED_SERVER = bindPHP_SERVER = php7.0PO_SERVER = dovecotSQL_SERVER = mariadb_10.2


    I´m running PhpSwitcher 3.0.6


    Here is the Error:

    Shell-Script
    1. #/var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler# perl php_compiler.pl 5.3[INFO] Make target set to `install'[INFO] Installing PHP build dependencies...Paketlisten werden gelesen... FertigAbhängigkeitsbaum wird aufgebaut.Statusinformationen werden eingelesen.... Fertiglibexpat1-dev ist schon die neueste Version (2.2.0-2+deb9u1).libexpat1-dev wurde als manuell installiert festgelegt.locales-all ist schon die neueste Version (2.24-11+deb9u1).autoconf ist schon die neueste Version (2.69-10).autoconf wurde als manuell installiert festgelegt.automake ist schon die neueste Version (1:1.15-6).automake wurde als manuell installiert festgelegt.build-essential ist schon die neueste Version (12.3).libmagic1 ist schon die neueste Version (1:5.30-1).libmagic1 wurde als manuell installiert festgelegt.flex ist schon die neueste Version (2.6.1-1.3).libedit2 ist schon die neueste Version (3.1-20160903-3).libedit2 wurde als manuell installiert festgelegt.libtool ist schon die neueste Version (2.4.6-2).libtool wurde als manuell installiert festgelegt.mime-support ist schon die neueste Version (3.60).netbase ist schon die neueste Version (5.4).netcat-traditional ist schon die neueste Version (1.10-41+b1).libldap2-dev ist schon die neueste Version (2.4.44+dfsg-5).libldap2-dev wurde als manuell installiert festgelegt.libpcre3 ist schon die neueste Version (2:8.39-3).libpcre3 wurde als manuell installiert festgelegt.re2c ist schon die neueste Version (0.16-2).re2c wurde als manuell installiert festgelegt.wget ist schon die neueste Version (1.18-5).zlib1g-dev ist schon die neueste Version (1:1.2.8.dfsg-5).Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dassSie eine unmögliche Situation angefordert haben oder, wenn Sie dieUnstable-Distribution verwenden, dass einige erforderliche Pakete nochnicht erstellt wurden oder Incoming noch nicht verlassen haben.Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:Die folgenden Pakete haben unerfüllte Abhängigkeiten: libmariadbclient-dev : Hängt ab von: libmariadbclient18 (= 10.1.23-9+deb9u1)[ERROR] main: An unexpected error occurred: An error occurred while installing build dependencies: E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

    Looks like there are other packages need for MariaDB 10.2 because i´m unable to find the libmariadbclient-dev for version 10.2.


    And of course, the installation aborts because of the wrong version.

    Here are all my installed Packages for MariaDB

    Shell-Script
    1. # dpkg-query -l '*maria*' | grep '^.i'ii libmariadb-dev 10.2.6+maria~stretch amd64 MariaDB database development filesii libmariadb3 10.2.6+maria~stretch amd64 MariaDB database client libraryii libmariadbclient18 10.2.6+maria~stretch amd64 Virtual package to satisfy external dependsii libmariadbd-dev 10.2.6+maria~stretch amd64 MariaDB embedded database, development filesii libmariadbd19:amd64 10.2.6+maria~stretch amd64 MariaDB embedded database, shared libraryii mariadb-client-10.2 10.2.6+maria~stretch amd64 MariaDB database client binariesii mariadb-client-core-10.2 10.2.6+maria~stretch amd64 MariaDB database core client binariesii mariadb-common 10.2.6+maria~stretch all MariaDB database common files (e.g. /etc/mysql/conf.d/mariadb.cnf)ii mariadb-server-10.2 10.2.6+maria~stretch amd64 MariaDB database server binariesii mariadb-server-core-10.2 10.2.6+maria~stretch amd64 MariaDB database core server files

    I´m not sure if there are there still some development files/packages missing ?


    Here is my sources.list

    Thanks for any help!

    Ich finde es super wenn sich jemand für etwas interessiert ist und engagiert ist zu lernen.
    Leider kann ich nicht einschätzen was Du schon kannst und was nicht. Am besten installierst Du i-MSCP in einer virtuellen Maschine und schaust Dir das ganze mal an.

    Quote

    Dies ist zum Beispiel für Monitoring-Systeme sehr hilfreich, da man nicht immer einen Account hierfür anlegen muss.


    Ich weis ja nicht wie viele Accounts Du für deine Monitoring-System benötigst. Aber bevor ich eine Anonyme Anmeldung aktiviere lege ich lieber einen Account an.
    Der Aufwand ist wirklich nicht riesig.