Posts by akong7777

    Hello, Ihas put patch to it path. I got error.

    What's this problem?

    Hello,

    I has install phpswitcher and want install php7.1

    But I got error.

    Code
    1. checking for xml2-config path...
    2. /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/Makefile:368: recipe for target 'configure-7.1-stamp' failed
    3. [ERROR] main: An unexpected error occurred: An error occurred while executing the install MAKE(1) target for php-7.1.11: aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
    4. ../configure: line 5383: test: too many arguments
    5. configure: error: xml2-config not found. Please check your libxml2 installation.
    6. make: *** [configure-7.1-stamp] Error 1

    I also check my system about libxml2-dev

    Code
    1. root@web1:/var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler# apt-get install libxml2-dev
    2. Reading package lists... Done
    3. Building dependency tree
    4. Reading state information... Done
    5. libxml2-dev is already the newest version (2.9.9+dfsg-1+0~20190828.2+debian9~1.gbp28a022).
    6. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    I has installed it. How to fix it?

    My system is debian 9.9 and install imscp 1.5.3-2018120800 version.

    error log:

    Code
    1. checking whether to enable internationalization support... yes, shared
    2. checking for icu-config... no
    3. checking for location of ICU headers and libraries... not found
    4. /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/Makefile:368: recipe for target 'configure-5.5-stamp' failed
    5. [ERROR] main: An unexpected error occurred: An error occurred while executing the install MAKE(1) target for php-5.5.38: aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
    6. configure: WARNING: bison versions supported for regeneration of the Zend/PHP parsers: 2.4 2.4.1 2.4.2 2.4.3 2.5 2.5.1 2.6 2.6.1 2.6.2 2.6.3 2.6.4 2.6.5 2.7 (found: 3.0).
    7. ../configure: line 5397: test: too many arguments
    8. configure: error: Unable to detect ICU prefix or no failed. Please verify ICU install prefix and make sure icu-config works.
    9. make: *** [configure-5.5-stamp] Error 1

    Because some web site need old system.So I need install imscp 1.3.16.

    I install imscp 1.3.16 on debian 8.But I got error.


    Code
    1. [ERROR] iMSCP::Composer::_installPackages: Could not install/update i-MSCP packages from GitHub
    2. autoinstaller::Functions::install: An error occurred while performing installation steps

    How to check it and fix it?