Posts by BInspiron

    Hi, I tried to update from i-MSCP 1.2.2 to 1.2.5.


    Stoped the three services (ismscp_panel, imscp_daemon, imscp_network) then try to exec "perl imscp-autoinstall -d".


    I've got this error message (from 70% of update):


    main::setupRebuildCustomerFiles:
    │ [WARN] iMSCP::Config::FETCH: Accessing non existing config value
    │ CMD_CHMOD from the /etc/imscp/imscp.conf file (see file
    │ /var/www/imscp/gui/plugins/SpamAssassin/backend/SpamAssassin.pm at line
    │ 425)
    │ iMSCP::Debug::__ANON__: Use of uninitialized value
    │ $imscpConfig{"CMD_CHMOD"} in concatenation (.) or string at
    │ /var/www/imscp/gui/plugins/SpamAssassin/backend/SpamAssassin.pm line 425.



    [ERROR] main::setupRebuildCustomerFiles:
    [WARN] iMSCP::Config::FETCH: Accessing non existing config value CMD_CHMOD from the /etc/imscp/imscp.conf file (see file /var/www/imscp/gui/plugins/SpamAssassin/backend/SpamAssassin.pm at line 425)


    After that unexpected exit, the mail services stopped.
    What can I do?

    Files

    AH00526: Syntax error on line 55 of /etc/apache2/apache2.conf:
    Invalid command 'LockFile', perhaps misspelled or defined by a module not included in the server configuration
    Action '-t' failed.
    The Apache error log may have more information.



    This is the line 55:


    LockFile ${APACHE_LOCK_DIR}/accept.lock

    Thanks Nuxwin!


    Ok, I did the mysqldump with this nice script.


    And now?
    Normal Ubuntu release upgrade.
    And after that?
    Reinstall i-MSCP?



    Hi,


    I have Ubuntu 12.04 LTS server with i-MSCP 1.2.2. (Build: 20150212)
    This version contains PHP Version 5.3.10.


    Unfortunately this version of PHP is very unstable, I got this message many times (and I need to restart PHP5-FPM service):


    [24-May-2015 08:21:14] WARNING: [pool mydomain.com] child 27199 exited on signal 11 (SIGSEGV - core dumped) after 21.651769 seconds from start
    [24-May-2015 08:21:14] NOTICE: [pool mydomain.com] child 27217 started
    [24-May-2015 08:21:30] WARNING: [pool mydomain.com] child 27217 exited on signal 11 (SIGSEGV - core dumped) after 16.533232 seconds from start
    [24-May-2015 08:21:30] NOTICE: [pool mydomain.com] child 27223 started
    [24-May-2015 08:21:32] WARNING: [pool mydomain.com] child 27223 exited on signal 11 (SIGSEGV - core dumped) after 2.053442 seconds from start
    [24-May-2015 08:21:32] NOTICE: [pool mydomain.com] child 27225 started
    [24-May-2015 08:21:33] WARNING: [pool mydomain.com] child 27225 exited on signal 11 (SIGSEGV - core dumped) after 1.133100 seconds from start
    [24-May-2015 08:21:33] NOTICE: [pool mydomain.com] child 27227 started


    I would like to update the PHP version to 5.5.25 stable version (or higher).
    How can I do it manually?


    Do I need to upgrade my Ubuntu server from 12.04 to 14.04?


    If I can update the PHP version, the next i-MSCP release will be working?


    Thank you!


    Here is my phpinfo head:


    PHP Version 5.3.10-1ubuntu3.18


    System Linux johndoe 3.13.0-49-generic #81~precise1-Ubuntu SMP Wed Mar 25 16:32:15 UTC 2015 x86_64
    Build Date Apr 17 2015 15:14:51
    Server API FPM/FastCGI
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /etc/php5/fpm
    Loaded Configuration File /etc/php5/fpm/php.ini
    Scan this dir for additional .ini files /etc/php5/fpm/conf.d
    Additional .ini files parsed /etc/php5/fpm/conf.d/10-mysqlnd.ini, /etc/php5/fpm/conf.d/apc.ini, /etc/php5/fpm/conf.d/curl.ini, /etc/php5/fpm/conf.d/gd.ini, /etc/php5/fpm/conf.d/imap.ini, /etc/php5/fpm/conf.d/intl.ini, /etc/php5/fpm/conf.d/mcrypt.ini, /etc/php5/fpm/conf.d/mysql.ini, /etc/php5/fpm/conf.d/mysqli.ini, /etc/php5/fpm/conf.d/pdo.ini, /etc/php5/fpm/conf.d/pdo_mysql.ini, /etc/php5/fpm/conf.d/suhosin.ini
    PHP API 20090626
    PHP Extension 20090626
    Zend Extension 220090626
    Zend Extension Build API220090626,NTS
    PHP Extension Build API20090626,NTS
    Debug Build no
    Thread Safety disabled
    Zend Memory Manager enabled
    Zend Multibyte Support disabled
    IPv6 Support enabled
    Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, zip, phar
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, tls
    Registered Stream Filters zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, mcrypt.*, mdecrypt.*

    You have right! :)


    I use i-MSCP 1.2.2 (Build: 20150212 Codename: Andromeda).


    The global apache conf is in /etc/apache2/apache2.conf ?


    I have exactly 70 domains with "average" small traffic (cca. 100 visitor/day/domain).


    Here are the main settings:


    I know what MaxClients means, but I tought if the server reaches this limit, the next connections will be denied, but after some session will be ended, the server will be ready again.
    Am I right?
    Or if the server reaches the MaxClients, then will be frozen immediately?