ClamAV plugin - Error with Clamav-milter

  • Hi buddies, I have a problem that has gone undetected on my server and with attachments of a certain size
    It is not capable of going through the antivirus, I always get the same error

    ERROR: clamfi_eom: FD send failed: Broken pipe
    ERROR: FD send failed

    I have reviewed the plugin config and this in 25 Mb,
    I have reviewed the config clamav-milter and this in 25 Mb,
    I have reviewed the config clamav and this in 25 Mb

    But still leaking the size in some settings,
    Any of you have had is small inconvenience

    I-MSPC currently used. 1.2.8, which is updated without problem since version 1.2
    It is using the latest version of the plugin
    Clamav Version 1.1.2

    thanks friends

    And do not spend much heat as here in Spain

  • I modified a configuration line in the /etc/clamav/clamav-milter.conf file

    I commented the line generated by the plugin

    1. #MilterSocket Inet: 32767 @ localhost

    and replaced it by this one

    1. MilterSocket /var/spool/postfix/clamav/clamav-milter.ctl

    And now I send without problems using the parameters MaxFileSize
    No one is more or less correct this change, but now I can send attachments, and set its size

    Now its my config and working fine:

  • Hello ;

    Default configuration is using TCP. Thus, this is maybe due to packet size limit. I must check that. We could use unix socket by default. I must process some test.

    Thanks you for your report ;)

    Thread moved in plugin support section.


  • @Ninos

    No, I must process some test before.


  • Good morning, @Ninos I'll prove this afternoon at home in a small vps, vps as the other awards were updated completely, I put the manual configuration.

    I try MaxFileSize parameter, with the new version of the plugin and tell the result

    thanks friend

  • Hello @Ninos, I'm sorry I was a bit tricky these days and I could not test until today

    I tried on a clean system with Debina jessie with the latest version of the plugin Version 1.1.3, and it continues with the same error

    Jul 30 21:11:44 server postfix/cleanup[25276]: BBDA01C14EE: milter-reject: END-OF-MESSAGE from[]: 4.7.1 Service unavailable - try again later