rm as root: Permission denied

  • Hey there,
    I've got a strange problem. I had a subdomain called old and so also a folder in:



    From admin panel I removed the subdomain, all worked without problems, only that the folder old (now empty) still exists. So I logged into ssh as root, tried to remove it and got this message:


    rm: cannot remove `old': Permission denied

    I also changed the folder permissions to 777, the user/group to root and something else and set the force parameter to rm (rm -Rf), but nothing helped. Does anyone have an idea where the problem could be?


  • Hi Ninos,

    have you checked the directory for the purpose of chattr (immutable bit)?

  • tried chattr -R -i old but didn't solve my problem :/

  • okay, really strange,
    I would check the file system.

  • I'll set it tonight into the rescue mode and try there to delete the folder &| check the system :)

  • Hello ;

    tried chattr -R -i old but didn't solve my problem :/

    Please, do this before:

    1. chattr -R -i /var/www/virtual/domain.tld
    2. rm -r /var/www/virtual/domain.tld/old

    because chattr -R -i on the old directory is not sufficient.