E-Mail Autoresponder

  • Hallo,


    when I activate E-Mail Autoresponder I can not receive the Mail.


    I become the Autoresponder that is all.


    At /var/mail/virtual/domain/new is not the Mail I have send.


    At /etc/postfix/imscp/aliases I see my e-Mail "viktor@imscp-arpl.domain".


    Can you help me.:huh:


    Kind regards,


    Viktor;)

    - Distribution: Debian | Release: 8.10 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)

    - LetsEncrypt (v 3.5.0), PhpSwitcher (v 5.0.5), RoundcubePlugins (v 2.0.2)

  • Add the mail address you want to receive the mails just before the arpl-entry - sep with comma:


    something like:


    viktor@domain [tab] viktor@domain,viktor@imscp-arpl.domain


    and postmap aliases...
    dont' forget the working copy... (I think you know the place...)



    But this should be tested and maybe it needs a ticket...


    /J

  • Addendum: I have the same behaviour - but I have beta 5.


    Do you have beta 6? then could you open a ticket please?


    /Joxi

  • .../imscp/engine/PerlLib/Servers/mta/postfix.pm


    somewhere around line 646 (on beta5):


    push(@line, $data->{MAIL_ADDR}) if $data->{MAIL_HAVE_CATCH_ALL} eq 'yes' && $data->{MAIL_TYPE} =~ m/_mail/;


    replace with:


    push(@line, $data->{MAIL_ADDR}) if $data->{MAIL_TYPE} =~ m/_mail/;



    this works at least for normal mail accounts - I could not test the catch-all thing...



    add:
    when removing the autoreply there's a line left in the aliases "mail@domain [tab] mail@domain" which seems to be useless but not a problem...)




    /J

    Edited once, last by joximu ().

  • correct: maybe the line to correct is some line below... in addMailForward...


    I'll check it later...



    ... too complex for the moment... I added a ticket....
    solution above works for now...

    Edited once, last by joximu ().

  • Please test rbe1eb32. Joximu you was really close :). I know logic there is pain in ass but database structure is pain in ass :(

  • Thanx Daniel -I changed the line in my beta 5 - and it works...


    I still think it should be possible with one sub which builds the line in aliases....
    I'll think about it...

  • Hallo,


    I have test it now and it's works.:)


    I become now two Autoresponder and the Mail.:huh:


    It is better but two Autoresponder is one to match.:D


    Kind regards,


    Viktor;)

    - Distribution: Debian | Release: 8.10 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)

    - LetsEncrypt (v 3.5.0), PhpSwitcher (v 5.0.5), RoundcubePlugins (v 2.0.2)