PhpSwitcher

  • PluginManager added a new file:

  • PhpSwitcher Plugin Version 0.0.2 has been released in plugin store.


    Version compatible with i-MSCP >= 1.1.1


    CHANGELOG

    • Added: Binary and configuration directory paths to datatable
    • Added: Optional but recommended memcached support
    • Removed: Version ID from datatable

    Documentation is available at http://wiki.i-mscp.net/doku.php?id=plugins:phpswitcher

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • I'd tested the version 0.0.2 on Debian Jessie.
    I'd compiled the php version 5.4.25 in through the folder "/opt/php-fcgid/5.4.25"
    In the config.php the memcached option is activated.

    Code
    1. PHP 5.4.25/opt/php-fcgid/5.4.25/bin/php-cgi/var/www/fcgi


    This is what i added in the interface.


    Now i wanted to change the value als customer, but the fcgi-wrapper script does not change.
    When i change the line

    Code
    1. exec /opt/php-fcgid/5.4.25/bin/php-cgi "$@"


    manually and set the default php (5.5) with the switcher, the value was set correctly. But it does not work with PHP 5.4.25.


    Can you check this too on Debian Jessie?

  • I'll recheck on wheezy with new install and also give a try to Jessie.


    Thanks for the report.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • I cannot confirm the problem with wheezy.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • I've found some small problems but this will be solved in version 0.0.3.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • PhpSwitcher Plugin Version 0.0.3 has been released in plugin store.


    Version compatible with i-MSCP >= 1.1.1


    CHANGELOG

    • Fixed: If the memcached server do not work, plugin must work in degraded mode
    • Fixed: Wrong package name in documentation for memcached support (perl side)

    Documentation is available at http://wiki.i-mscp.net/doku.php?id=plugins:phpswitcher

    Files

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • I have just tested it with the latest version of 0.0.3 and unfortunately it's not for me it is still PHP 5.4.25-1 ~ dotdeb.1 (cli) (built: Feb 10 2014 04:09:23)

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)


    https://www.4sync.com/web/r/dwMJ2VT4

  • Hello ;


    More info please...


    How do you have installed the plugin exactly? What is the PHP version you have compiled? How do you have registered your PHP version in PhpSwitcher interface (what parameters did you entered)? Do you have enabled memcached support? Which implementation of the httpd server do you use? Fcgid? PHP5-FPM?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206