php8 with PHPSwitcher

  • hello

    debian 9.13

    imscp 1.5.3


    i try to install php 8.0

    i do what i see in this forum

    and

    Code
    1. perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl --register --packaged --install-dir /opt/my/install/directory 8.0

    no error


    but in imscp panel in PHPSwitcher i don't see php8

    Code
    1. Version Type Binaire FastCGI Binaire FPM Nom du service FPM Statut Actions
    2. 7.1.33 (défaut) Empaquetée /usr/bin/php-cgi7.1 /usr/sbin/php-fpm7.1 php7.1-fpm Ok N/A
    3. 7.3.11 Compiled /opt/phpswitcher/static/php7.3/bin/php-cgi /opt/phpswitcher/static/php7.3/sbin/psw7.3-fpm psw7.3-fpm Ok
    4. 7.4.0RC4 Compiled /opt/phpswitcher/static/php7.4/bin/php-cgi /opt/phpswitcher/static/php7.4/sbin/psw7.4-fpm psw7.4-fpm Ok
    5. 5.6.40 Compiled /opt/phpswitcher/static/php5.6/bin/php-cgi /opt/phpswitcher/static/php5.6/sbin/psw5.6-fpm psw5.6-fpm Ok


    i go to see by ftp in

    Code
    1. /opt/phpswitcher/static/

    nothing for php8


    i go to see in /opt/my/install/directory

    i see php5.6 7.3 7.4 and php8.0 but in php8.0 only etc with directori php and inside diretorie conf.d (empty) and file php.ini


    can you help me please


    thanks

    stephan

    IMSCP 1.5.3
    DEBIAN 9

  • To use the packaged version, you have to first install all the dependencies (install PHP8).


    Only after you can register the packaged version.


    PS : Install dir is not used from what I remember... it's only needed for compiled version.

  • thanks for your help

    I am a beginner

    how i install all the dependencies (install PHP8)


    thanks

    IMSCP 1.5.3
    DEBIAN 9

  • after instalaltion php8

    i make

    Code
    1. perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl --register --packaged --install-dir /opt/my/install/directory 8.0

    and always nothing

    IMSCP 1.5.3
    DEBIAN 9

  • Because, what you follow is not the good thing to do :D


    In normal time, I would I say "Read the wiki", but the certificate isn't yet updated, so :

    Code
    1. apt install php8.0-cli php8.0-cgi php8.0-fpm


    After this, you can do the register (and remove this fucking "install-dir" option, not needed, you don't install anything there)



    Oh, and use the edit function, don't do multi-post like this... I could close the thread quite fast :D

  • thanks for help

    but it's already installed

    Code
    1. apt install php8.0-cli php8.0-cgi php8.0-fpm
    2. Lecture des listes de paquets... Fait
    3. Construction de l'arbre des dépendances
    4. Lecture des informations d'état... Fait
    5. php8.0-cgi is already the newest version (8.0.13-1+0~20211122.27+debian9~1.gbp1675bc).
    6. php8.0-cli is already the newest version (8.0.13-1+0~20211122.27+debian9~1.gbp1675bc).
    7. php8.0-fpm is already the newest version (8.0.13-1+0~20211122.27+debian9~1.gbp1675bc).
    8. 0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

    IMSCP 1.5.3
    DEBIAN 9

  • Code
    1. p# apt install php-pear
    2. Lecture des listes de paquets... Fait
    3. Construction de l'arbre des dépendances
    4. Lecture des informations d'état... Fait
    5. php-pear is already the newest version (1:1.10.12+submodules+notgz+20210212-1+0~20210228.21+debian9~1.gbpf2b98f).
    6. 0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

    IMSCP 1.5.3
    DEBIAN 9