Php switcher php 5.6 version.

  • /opt/phpswitcher/20201214/php5.6/bin/pecl install memcache


    pecl/memcache requires PHP (version >= 8.0.0), installed version is 5.6.32

    No valid packages found

    install failed

    root@vmi271578:/opt/phpswitcher/20201214/php5.6/bin#


    /opt/phpswitcher/20201214/php5.6/bin/pear install memcache

    PHP Warning: PHP Startup: Unable to load dynamic library '/opt/phpswitcher/20201214/php5.6/lib/php/20131226/memcache.so' - /opt/phpswitcher/20201214/php5.6/lib/php/20131226/memcache.so: cannot open shared object file: No such file or directory in Unknown on line 0

    PHP Warning: PHP Startup: Unable to load dynamic library '/opt/phpswitcher/20201214/php5.6/lib/php/20131226/memcached.so' - /opt/phpswitcher/20201214/php5.6/lib/php/20131226/memcached.so: cannot open shared object file: No such file or directory in Unknown on line 0

    No releases available for package "pear.php.net/memcache" - package pecl/memcache can be installed with "pecl install memcache"

    install failed

  • Succes!!!

    Debian command 100% working..


    INSTALL EXTENSION:


    /opt/phpswitcher/20201214/php5.6/bin/pecl install memcache-3.0.8

    /opt/phpswitcher/20201214/php5.6/bin/pecl install memcached-2.2.0


    sudo service memcached restart

    /etc/init.d/psw5.6-fpm restart

    /etc/init.d/apache2 restart


    Build process completed successfully

    Installing '/opt/phpswitcher/20201214/php5.6/lib/php/20131226/memcache.so'

    install ok: channel://pecl.php.net/memcache-3.0.8

    configuration option "php_ini" is not set to php.ini location

    You should add "extension=memcache.so" to php.ini


    But for something yet the memcache the phpinfo did not appear on a side


    php.ini:

    /opt/phpswitcher/20201214/php5.6/etc/php/conf.d/modules.ini


  • Code
    1. Additional .ini files parsed /opt/phpswitcher/20201214/php5.6/etc/php/conf.d/memcache.ini, /opt/phpswitcher/20201214/php5.6/etc/php/conf.d/memcached.ini, /opt/phpswitcher/20201214/php5.6/etc/php/conf.d/memcachedk.ini, /opt/phpswitcher/20201214/php5.6/etc/php/conf.d/modules.ini

    Fatal error: Class 'Memcache' not found in

  • ps aux | grep memcached

    memcache 8964 0.2 0.0 63392 2676 ? Ssl 14:07 0:00 /usr/bin/memcache -m 64 -p 11211 -u memcache -l 127.0.0.1

    root 8973 0.0 0.0 12884 952 pts/0 S+ 14:08 0:00 grep --color=auto memcached


  • What problem not memcache??

    the memcache anything plugin his requirement?

  • Please use sury.org to install all your needed PHP versions and additional modules.

    Easyer, always up to date and simply working !

    You did not prepare it the phpswitchert? Should you not know his function? I do not know it unfortunately what És works as how only kb I found it out after sitting before 5 daily machines that debian setup is needed. But nothing I do not get help for my money?