phpswitcher: Add recent version for PHP 7.4

  • Hi,


    the phpswitcher plugin still installs 7.4RC4, while the most recent version is 7.4.11


    Would it be possible to add a recent version, or at least an official release?

    Manually changing the plugin results in an error while applying patches.


    Also, is it possible to change the default php version from 7.1 to at least 7.3 (which is the oldest version to get security updates)?


    Thank you.

  • Hello,


    look here: PhpSwitcher


    Viktor

    - Distribution: Debian | Release: 8.10 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)

    - LetsEncrypt (v 3.5.0), PhpSwitcher (v 5.0.5), RoundcubePlugins (v 2.0.2)

  • Hi Victor,


    thank you for this hint.


    I'm not sure if I understand this correctly. I do have PhpSwitcher 5.0.5 installed, which on my system compiles 7.4RC4

    Was a new phpswitcher version released under the same version number?


    Best regards,

    Sven.

  • Ah, sorry, got your change in php_compiler.pl now, but I'm getting errors, when I try to compile 7.4.6 ...

  • Ah, sorry, got your change in php_compiler.pl now, but I'm getting errors, when I try to compile 7.4.6 ...

    Just edit /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl accordingly



    my System :

    - Distribution: Debian | Release: 9.13 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), SpamAssassin (v 2.0.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 5.0.5), RoundcubePlugins (v 2.0.2)YubiKeyAuth 1.1.0

  • As I mentioned in my first post, changing to 7.4.11 fails when applying patches, while setting it to 7.4.6 fails with the error in comment #4

  • As I mentioned in my first post, changing to 7.4.11 fails when applying patches, while setting it to 7.4.6 fails with the error in comment #4

    there was a patch for this problem.

    my System :

    - Distribution: Debian | Release: 9.13 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), SpamAssassin (v 2.0.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 5.0.5), RoundcubePlugins (v 2.0.2)YubiKeyAuth 1.1.0

  • Hello,


    jo the patcht "0029-php-5.4.9-fixheader.patch" was change.



    Kind regards

    Viktor

    - Distribution: Debian | Release: 8.10 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)

    - LetsEncrypt (v 3.5.0), PhpSwitcher (v 5.0.5), RoundcubePlugins (v 2.0.2)