Cannot install with (Docker on Debian Stretch)

  • Right now I'm trying to install IMSCP via docker,

    which I noticed early on that the Preseed is very peculiar.

    Furthermore, no MYSQL server is started during the installation, which seems to make an installation impossible.

    I have started it manually via Docker Shell, but now the following error occurs, no matter what I enter.


    Hier ist meine preseed

  • HellBz

    Changed the title of the thread from “Cannot install with” to “Cannot install with (Docker on Debian Stretch)”.
  • I use a DOCKER in Windows and use Debian Stretch for System for Dockerimage.

    So what is wrong here, I had problems installing IMSCP on my Debian before.

    Unfortunately I can't quite interpret the statement of tracer here, because I use a LINUX image here.

    And yes this is a REAL LInux image.

    Here is my docker file, which doesn't matter that the installer doesn't work correctly with the PreSeed.

    An empty preseed does even less.

  • Did you git clone the latest unrealeased version ? (which is not "stable" by definition as all tests hasn't been done on it) or did you get the release packaged ? (1.5.3 build 2018120800)

    If you take the first one, there "might" be some issues with the preseed way of setup.

    If you take the package of the latest known good build, PHP.7.4 is not supported (7.1 at maximum).

    Even, I'm not sure that the PHP7.4 is working for the "dev" build (preseed example stop at 7.3 after all).

  • Why Docker when you have got an Debian at hands?

    If you got isues installing it under Debian you could find help, but why install it in a container inside a real OS?

  • I'm pretty sure that, if you try to setup the latest released build, you use the same preseed file you posted which will explain the Fatal error.…018120800/docs/

    This is the preseed file for the 1.5.3 build 2018120800.

    Also, there is no official support of Docker use, and like "tracer", I wonder why you attempt this ?

    If you just want to test the panel, like he said, just do a Debian or Ubuntu VM, easier and working at least.

  • It's not about whether I run the installer on a normal Debian virtual machine or a docker,

    Basically it is about the fact that the installer ( Tested on the 1.5.3 and on the 1.5.3-800 ) does not work in any configuration.

    I have tried everything with a BLANK-Config, also without success.

    Apparently no one seems to understand this, but always blame it on other contingencies like dockers and question this.

  • Pity, no one likes to help, problems that occur are only postponed to one self or other factors.

    The normal installation under Debian unfortunately also runs anything but smoothly.

    Thanks? partly...

    Change to another tool after many years