Lets encrypt unexpected error

  • Hi there,


    after the whole php plugin switcher update to support 7.3 etc. there seems to be an issue with my local lets encrypt instance.

    It tells me that the apt target packages are configured multiple times in sources.list and in sources.list/php.list witch is correct.

    But the question is what should I do to resolve this? In php.list there is just one line, which is the same as in sources.list . So should I remove this line in php.list?


    The line is:

    Code
    1. deb https://packages.sury.org/php/ stretch main


    I'm using i-MSCP 1.5.3 Build: 20180516

    And Debian stretch

    Plugins are both the newest version.

    LE: 3.5.0

    PHP: 5.0.5


    This is the error provided by the LE plugin:

    Code
    1. Ein unerwarteter Fehler ist aufgetreten:
    2. Plugin::LetsEncrypt::enable: W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:20 and /etc/apt/sources.list.d/php.list:1
    3. W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:20 and /etc/apt/sources.list.d/php.list:1
    4. W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:20 and /etc/apt/sources.list.d/php.list:1
    5. W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:20 and /etc/apt/sources.list.d/php.list:1
    6. W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:20 and /etc/apt/sources.list.d/php.list:1
    7. W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:20 and /etc/apt/sources.list.d/php.list:1
    8. E: Unable to correct problems, you have held broken packages. at /var/www/imscp/gui/plugins/LetsEncrypt/backend/LetsEncrypt.pm line 266.

    stay hungry, stay foolish!

  • First you need to upgrade to latest I-MSCP Version! Otherwise we can not really help you!

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.27 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • But the question is what should I do to resolve this? In php.list there is just one line, which is the same as in sources.list . So should I remove this line in php.list?

    Yes. You have a duplicate entry. Have a look in the "/etc/apt/source.list". There you will find the entry from the i-MSCP installer

  • Yes. You have a duplicate entry. Have a look in the "/etc/apt/source.list". There you will find the entry from the i-MSCP installer

    Hi TheCry thanks for your reply!



    Ok and which entry should I delete? The one in apt/sources.list

    or the one in php.list?

    stay hungry, stay foolish!

  • Like you want. I prefer to delete php.list, because you added this by yourself. The entry in the source.list was added by the i-MSCP installer