DNS Resolver

  • Hello,

    I have the problem, that spamassassin is blocked from some blacklists, for checking.

    1. SURBL_BLOCKED=0.001

    I tried this instruction. https://www.syn-flut.de/caching-dns-resolver-mit-bind9

    But it's still not working. The /etc/resolv.conf will be always reset. Spamassassin use always the original settings.

    Can someone help me, please?

    I-MSCP 1.5.3 on Debian

    Edited once, last by rr10111101 ().

  • I'm pretty sure that SpamAssassin is not blocked from some blacklists…

    By the way, if your server is blocking someone because It's present in some blacklists, that's not your problem.

    Else, if you're blocked because you're present in some blacklists… well that's your problem.

    You need to see why (could be a lot of reasons)…

    A good starting point could be that one: https://mxtoolbox.com/blacklists.aspx

  • This happend to me also. Some RBLs got rate-limits. I sipmply add a forwarder to the google DNS.

    1. zone "DNSRBL.ZONE.HERE." {
    2. type forward;
    3. forwarders{; };
    4. };