[PHPSwitcher]Problems while compiling php version

  • Hello together,

    I have some difficulties while compiling the PHP Versions with followin command:

    1. perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl 7.2 7.2

    As soon as I start this command, I get this error message:

    If I trie the installation without a specific version, I get following error message:

    I tried the following:

    • Reinstallation for phpswitcher
    • The file "psw-debian-stretch.cow" is not available
    • Reinstallation for pbuilder
    • Reinstallation for i-MSCP (with Windows it actually also helps :thumbsup:)

    I have tried further:

    • Manually creating the path "var/cache/pbuilder/psw-aptcache-debian-stretch" - unfortunately I have got the next error message

      [ERROR] main: An error occurred while setup of PHP build environment: debconf: delaying package configuration, since apt-utils is not installed
      debconf: delaying package configuration, since apt-utils is not installed
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      E: pbuilder create failed

      When I try to reinstall apt-utils, I get the message, that version 1.4.9 is already installed

    I am using the following components:

    • i-MSCP 1.5.3 - Build: 2018120800
    • PHP Switcher - Version 5.0.5 (Build 2019102300)
    • Debian GNU/Linux 9.11 (stretch)

    Some needed logs I have seen in the rule:

    Does someone has an idea?

    Best regards from Germany


    Edited 2 times, last by MiGro94 ().

  • What does the mistake you mentioned have to do with my mistake?

    My problem was unfortunately not solved by your suggested solution.

    Unfortunately there is some other strange problem here.

    It seems to me that there are some right mistakes, possibly permissions.

    Now I have tried the following Solution: Switcher 5.0.1 compile errors & > 5.0.2 Upg Error

    I have upgraded here, too - but i do not know from which version at the moment

    After reinstallation I have got the error message, that one directory is missing:

    I have created it manually, now I have got the following error message:

    Edited once, last by MiGro94 ().