PhpSwitcher - version 5.0.5 - DataTables warning

  • Hi All,


    I updated from 4.0.3 to 5.0.5.
    I installed php 7.4 packages.
    I run: perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl –register –packaged –packaged-only 7.4

    When I tried to switch in customer account, I see this error message:
    DataTables warning: table id=DataTables_Table_0 - Requested unknown parameter '2' for row 0. For more information about this error, please see http://datatables.net/tn/4
    I couldn't switch php version.

    Debian 9, up-to-date
    i-MSCP 1.5.3
    Build: 2018120800
    Codename: Ennio Morricone


    I tried this plugin update one other system. I thought the version jump was big in last time. But no.
    4.0.3-> 5.0.0
    The same error message.


    ..and from this time the phpswitcher doesn't work and I can't downgrade.

    What is the problem with v5.x ?



    Files

    • bug.png

      (55.73 kB, downloaded 8 times, last: )
  • Don't know what to tell you, for me everything is running correctly with every configured PHP version.


    Please fire the following commands:

    Code
    1. /var/www/imscp/engine/setup/imscp-reconfigure -danv

    and then:

    Code
    1. /var/www/imscp/engine/imscp-rqst-mngr -v

    The first one could take a while, depending on how much users/domains/mailboxes/etc you manage, the second one in less than a second.


    Clear your browser cache and try again...

  • Thank you for your answer.

    I tried this commands, but the error is same.

    I have just tired 3th server, same problem :(

  • The first command has last line:

    [WARN] Plugin::PhpSwitcher::resetHttpServerSettings: Use of uninitialized value in sprintf at /var/www/imscp/gui/plugins/PhpSwitcher/backend/PhpSwitcher.pm line 1110.