[Resolved ] I cannot use any PHP version with PHPSwitcher 5.0.5

  • I installed the php 5.6 7.1 7.2 7.3 7.4 versions in the db in the php_switcher_version table I see the configuration of the various versions of php, in the control panel of the plugin comes out "Bad Request", while in the domain management I see all the php version available but not are selectable, if I re-run the configuration it exits


    perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl --zts --packaged --register 5.6 7.1 7.2 7.3 7.4


    [INFO] Registering PHP versions in the PhpSwitcher plugin...


    [INFO] Registering the packaged PHP 5.6 version with data:




    - PEAR directory path : /usr/share/php


    - FastCGI binary path : /usr/bin/php-cgi5.6


    - FPM binary path : /usr/sbin/php-fpm5.6


    - FPM configuration file path : /etc/php/5.6/fpm/php-fpm.conf


    - FPM pool directory path : /etc/php/5.6/fpm/pool.d




    [INFO] Registering the compiled PHP 7.1 version with data:




    - PEAR directory path : /opt/phpswitcher/static/php7.1/share/pear


    - FastCGI binary path : /opt/phpswitcher/static/php7.1/bin/php-cgi


    - FPM binary path : /opt/phpswitcher/static/php7.1/sbin/psw7.1-fpm


    - FPM configuration file path : /opt/phpswitcher/static/php7.1/etc/php-fpm.conf


    - FPM pool directory path : /opt/phpswitcher/static/php7.1/etc/php-fpm.d




    [INFO] Registering the compiled PHP 7.2 version with data:




    - PEAR directory path : /opt/phpswitcher/static/php7.2/share/pear


    - FastCGI binary path : /opt/phpswitcher/static/php7.2/bin/php-cgi


    - FPM binary path : /opt/phpswitcher/static/php7.2/sbin/psw7.2-fpm


    - FPM configuration file path : /opt/phpswitcher/static/php7.2/etc/php-fpm.conf


    - FPM pool directory path : /opt/phpswitcher/static/php7.2/etc/php-fpm.d




    [INFO] Registering the compiled PHP 7.3 version with data:




    - PEAR directory path : /opt/phpswitcher/static/php7.3/share/pear


    - FastCGI binary path : /opt/phpswitcher/static/php7.3/bin/php-cgi


    - FPM binary path : /opt/phpswitcher/static/php7.3/sbin/psw7.3-fpm


    - FPM configuration file path : /opt/phpswitcher/static/php7.3/etc/php-fpm.conf


    - FPM pool directory path : /opt/phpswitcher/static/php7.3/etc/php-fpm.d




    [INFO] Registering the compiled PHP 7.4 version with data:




    - PEAR directory path : /opt/phpswitcher/static/php7.4/share/pear


    - FastCGI binary path : /opt/phpswitcher/static/php7.4/bin/php-cgi


    - FPM binary path : /opt/phpswitcher/static/php7.4/sbin/psw7.4-fpm


    - FPM configuration file path : /opt/phpswitcher/static/php7.4/etc/php-fpm.conf


    - FPM pool directory path : /opt/phpswitcher/static/php7.4/etc/php-fpm.d




    [DONE] PHP versions scheduled for update:


    - PHP 5.6 (Packaged)


    - PHP 7.1 (Compiled)


    - PHP 7.2 (Compiled)


    - PHP 7.3 (Compiled)


    - PHP 7.4 (Compiled)





    Default PHP Version in use: 5.6.40-14+0~20191128.24+debian9~1.gbpa5b195
    I-MSCP Version: [tt]i-MSCP 1.5.3 Build: 2018120800 Codename: Ennio Morricone

    OS: Debian 9.11 stretch
    Phpswitcher Version: Current 5.0.5

    Additional PHP version installed from package and used in phpswitched 7.1 7.2 .7.3 .74



    the plugin log does not report errors

    I also ran the "perl /usr/local/src/imscp-1.5.3/imscp-autoinstall -a -s -r httpd" command but without result


    Edit : I restarted the server and gave the command above "perl /usr/local/src/imscp-1.5.3/imscp-autoinstall -a -s -r httpd" and the problem was solved



    command but with no result
    How can I solve the problem ?

    P.S : image error2.png is old file

    Files

    • error2.png

      (27.34 kB, downloaded 8 times, last: )
    • error.png

      (57.32 kB, downloaded 9 times, last: )

    Notelseit.com

    Edited once, last by theprincy: Resolved ().

  • theprincy

    Changed the title of the thread from “I cannot use any PHP version with PHPSwitcher 5.0.5” to “[Resolved ] I cannot use any PHP version with PHPSwitcher 5.0.5”.