LetsEncrypt Certificate on Site using Firefox throws SEC_ERROR_REVOKED_CERTIFICATE

  • I use both Chrome and Firefox to verify the function ability of my Websites. Today all of my sites on my server are showing SEC_ERROR_REVOKED_CERTIFICATE but only on Firefox 70.0.1 64-bit. I am running the sites off of I-MSCP 1.5.3 and using the Letsencrypt Plugin 3.5.0. I added a site to the server yesterday without a problem. Is this a server cache problem? One last thing, I cloned the server and ran I-MSCP Perl install script on the clone to change IP address, the clone is working fine. I removed some sites on the clone that were on the original server without revoking the certificates first. If this is the problem how can I clean up the old certificates from the clone?

  • Hello Jaxson25

    You need to renewal your certs from admin panel!

    I don´t know why the cert´s where revoked!

    Please provide us with log-files or / and further informations about the cert status in your panel.

    Best regards

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.27 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • Tried to fix by renewing Certificate through the CP but that didn't help. Went back in and first Revoked the Certificate and then Renewed Certificate and that worked like a charm. I thought there was a more complicated problem since I had Cloned the server, but it turned out this simple solution did the trick.

    Thanks FloRet88 for the quick reply and simple advice, I wish more things in life could be solved so quickly. :thumbsup: