Invalid plugin archive: The 'name' plugin info field is missing.

  • Hi,


    I just tried to install a fresh debian 10.1 with the latest (1.5.3 maintenance) Version of i-MSCP and can not install any plugins.

    Apache 2.4.38


    The error it shows is:


    Quote


    Invalid plugin archive: The 'name' plugin info field is missing.

    It is a qemu VM so the virtualisation should not bother.


    The following Information can be found in the setup logs:


    Code
    1. [Thu Nov 7 10:33:54 2019] [debug] autoinstaller::Adapter::DebianAdapter::_installPackages: E: Can't select installed nor candidate version from package 'libdigest-md5-perl' as it has neither of them
    2. E: Can't select installed nor candidate version from package 'php5.6-phar' as it has neither of them
    3. E: Can't select installed nor candidate version from package 'php7.0-phar' as it has neither of them
    4. E: Can't select installed nor candidate version from package 'php7.1-phar' as it has neither of them
    5. E: Can't select installed nor candidate version from package 'php7.2-phar' as it has neither of them
    6. E: Can't select installed nor candidate version from package 'php7.3-phar' as it has neither of them
    7. E: Can't select installed nor candidate version from package 'php7.4-phar' as it has neither of them

    The table looks like this:

    Code
    1. 1 plugin_idPrimärschlüssel int(11) UNSIGNED Nein kein(e) AUTO_INCREMENT
    2. 2 plugin_nameIndex varchar(50) utf8mb4_unicode_ci Nein kein(e)
    3. 3 plugin_info text utf8mb4_unicode_ci Nein
    4. 4 plugin_config text utf8mb4_unicode_ci Ja
    5. 5 plugin_config_prev text utf8mb4_unicode_ci Ja
    6. 6 plugin_priorityIndex int(11) UNSIGNED Nein 0
    7. 7 plugin_statusIndex varchar(255) utf8mb4_unicode_ci Nein kein(e)
    8. 8 plugin_errorIndex text utf8mb4_unicode_ci Ja
    9. 9 plugin_backend varchar(3) utf8mb4_unicode_ci Nein no
    10. 10 plugin_lockers text utf8mb4_unicode_ci Ja

    Do you need any other logfiles?

    Best reagrds

  • He is talking about maintenance branch so yes, buster is supported but there is still some bugs with plugin manager ;)

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • I have the same issue with Devuan ASCII.

    Is there any version where the Switcher is currently working with 1.5.3-Git?