PhpSwitcher error install MAKE

  • Referring this Thread --> PhpSwitcher - Couldn't compille PHP 5.3 on Ubuntu 16.04 (Xenial) i have the same issue.


    Code
    1. /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/Makefile:368: die Regel für Ziel „configure-5.3-stamp“ scheiterte
    2. [ERROR] main: An unexpected error occurred: An error occurred while executing the install MAKE(1) target for php-5.3.29: aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
    3. ext/pdo_dblib/config.m4:56: warning: AC_CACHE_VAL(pdo_inc_path, ...): suspicious cache-id, must contain _cv_ to be cached



    4.4, 5.2 running fine, but i get this error at 5.3

    Code
    1. # perl php_compiler.pl --auto-setup 4.4 5.2 5.3 5.4 5.5 5.6 7.0 7.1


    i-MSCP 1.5.3

    Build: 20180516


    PhpSwitcher Version 4.0.3 (Build 2017111000)

    Installed PHP-Version 5.6


    It affects my intranet server for testing, so do not hurry for an answer ;)


    Edited once, last by root666 ().

  • I dont know if i can use this solution from this Thread --> Error Compiling PHP Versions for PHP Switcher


    Ubuntu based at Debian but i dont do experiments in apt what can eventually corrupt my whole system.

    Good evening,


    Please, edit the /etc/apt/preferences.d/imscp APT preferences file, then remove the first stanza (3 lines) which describe a pinning on ssl packages, then run apt-get update && apt-get dist-upgrade. Once done, retry. Note that you should avoid PHP 4.4 and 5.2.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Good evening Nuxwin,


    thank you for your answer.


    It was the second stanza for me:


    after commenting out the following lines in /etc/apt/preferences.d/imscp:

    Code
    1. #Package: openssl libssl-dev
    2. #Pin: release o=Ubuntu,n=xenial
    3. #Pin-Priority: 1002

    it has updatet after apt update && apt dist-upgrade the following:

    Code
    1. Die folgenden Pakete werden aktualisiert (Upgrade):
    2. libssl-dev openssl


    and now it seems the compiler runs fine.



    Note that you should avoid PHP 4.4 and 5.2.

    What do you mean exactly with this? Do you mean avoid at live systems (this is my test-intranet-server without access from the Internet) or do you mean avoid compiling with the updated libssl-dev and openssl?


    Thank you for your help and greetings from Germany.

  • What do you mean exactly with this? Do you mean avoid at live systems (this is my test-intranet-server without access from the Internet) or do you mean avoid compiling with the updated libssl-dev and openssl?

    You should avoid to compile those PHP versions, that is, make them available for your customers. Those PHP versions don't support FPM and are really too old. Support for them will be removed in next PhpSwitcher plugin version, according poll result we made some months ago. Of course you do as you want.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Nuxwin

    Added the Label solved
  • Thanks for the info, I know that you should not use older php versions as 5.6 already because of the security of the entire server. On my live system only 5.6 and higher is used for my customers.


    I am very sad to hear that 5.2 and older will soon be unsupported.


    In my case, I also use my intranet server as an archive server for old websites and projects. Many of them only run on older php versions (<=5.2) due to their scripts. That's why they were taken offline and reworked with newer scripts to continue to operate on live systems.


    Will there be a way for me to keep this archive in the future with i-MSCP and PhpSwitcher?

    A manual way for me to still compile and use these old versions?


    Otherwise, I'll probably have to archive the archive server and use a second test-intranet-server :D

    Edited once, last by root666 ().

  • I am very sad to hear that 5.2 and older will soon be unsupported.

    This is the result of a poll. See PhpSwitcher plugin - Should we drop support for PHP versions older than 5.3, that is, PHP 4.4 and 5.2?


    On your older server, you can always make use of the old PhpSwitcher version.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Just to add on this topic: root666 if you are sad on dropped php5.2 support only, there are only few functions that were changed w/o backward compatibility, and those are pretty rare used. https://www.php.net/manual/de/migration53.incompatible.php

    In php5.3 disable "deprecated" warnings, and 99.99% should be ok. There are mostly security holes closed in php5.3 against 5.2. Even such a shithole like Joomla 1.5.x works fine (which i really suggest not to use and to disallow to your customers at all!)

  • Thanks for the info Nuxwin and flames , i have testet these old sites (some with old Versions of PHPKit) with php5.3 and seems they works fine with it. Im glad to see i have an option for the future to keep running these old sites on my archive-intranet-server. Thank you very much for your support and the infos.