Unknown error raised while new client account creation (Awstats package related)

  • Hi there,


    i do get a "unknown error" message when I try to create a new customer.


    I'm using i-MSCP 1.5.3 and it's a brand new install.


    In the domain-status I do see this:


    Code
    1. iMSCP::File::save: Couldn't open `/etc/awstats/awstats.test-ds.de.conf' file for writing: No such file or directory
  • Good evening,

    • i-MSCP 1.5.3 build is ?
    • Does the /etc/awstats directory exists on the file system?
    • Do you have selected the Awstats package while i-MSCP installation or not?
    • Result of the following command is?: grep WEBSTATS_PACKAGES /etc/imscp/imscp.conf

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Nuxwin

    Added the Label awaiting Information
  • Nuxwin

    Changed the title of the thread from “unknown error when creating a new customer” to “Unknown error raised while new client account creation (Awstats package related)”.
  • Good evening,

    • i-MSCP 1.5.3 build is ?
    • Does the /etc/awstats directory exists on the file system?
    • Do you have selected the Awstats package while i-MSCP installation or not?
    • Result of the following command is?: grep WEBSTATS_PACKAGES /etc/imscp/imscp.conf

    Hi Nuxwin ,


    - 2018120800

    - no the directory doesn't exist

    - yes i did choose the awstats package during the install (but seems that there is no awstats installed??)

    - WEBSTATS_PACKAGES = Awstats

    stay hungry, stay foolish!

  • nextx42

    1. Are you sure you didn't remove the awstats debian package by mistake?
    2. Your distribution and code name is?
    3. Please try to rerun the installer to see if the package get re-installed: perl imscp-autoinstall -d


    Thank you.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • nextx42

    1. Are you sure you didn't remove the awstats debian package by mistake?
    2. Your distribution and code name is?
    3. Please try to rerun the installer to see if the package get re-installed: perl imscp-autoinstall -d


    Thank you.

    Hi Nuxwin ,


    1. nope. Brand new machine just installed i-mscp and used the i-mscp interface after that

    2. Debian 9 (stretch)

    3. should i run and download the installer or should i run the reconfigure?

    stay hungry, stay foolish!

  • should i run and download the installer or should i run the reconfigure?

    Read my previous answer correctly.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Ok so i've just run the installer in auto mode. Now there is no error anymore.


    Thanks!

    stay hungry, stay foolish!

  • FloRet88

    Set the Label from awaiting Information to not a bug