Error while updating to 1.5.3 (2018120800) - Failed to get unit file state for networking.service

  • Hello again,


    as Nuxwin stated here, I updated the i-mscp instance to the new build number, while a new error occured.


    Distro: Debian Jessie 8.7

    I-MSCP Version: 1.5.3 (error with newest build number in the last step)


    In the last step of the updating process, the installer aborted with the following error.


    Code
    1. [ERROR] main::setupDbTasks: Modules::ServerIP::add: Failed to get unit file state for networking.service: No such file or directory at /usr/local/src/imscp-1.5.3-2018120800/engine/PerlLib/iMSCP/Provider/Service/Debian/Systemd.pm line 64.
    2. ...propagated at /usr/local/src/imscp-1.5.3-2018120800/engine/PerlLib/iMSCP/DbTasksProcessor.pm line 496.
    3. [ERROR] autoinstaller::Functions::install: An error occurred while performing installation steps


    Didn't had such problems before. And we don't want to update to Debian Stretch, because we're already setting up an new server with the newest Debian and I-MSCP Version. We just want to update the old one, as stated from Nuxwin , to prevend any more complications while we're migrating our pages and projects one by one. The error points to an missing file in the update folder, is this correct?


    Kind regards,

    freedom

  • Re,


    There is no missing file... I'll make a test on Debian Jessie. As I suspect, systemd version from jessie is not able to say if one service is enabled when only the sysvinit script is provided. Give me some minutes to investigate please.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • freedom


    I cannot reproduce the issue.


    Distribution version

    Shell-Script
    1. root@jessie64:/usr/local/src/imscp-1.5.3-2018120800# lsb_release -a
    2. No LSB modules are available.
    3. Distributor ID: Debian
    4. Description: Debian GNU/Linux 8.11 (jessie)
    5. Release: 8.11
    6. Codename: jessie

    Systemd version

    Shell-Script
    1. root@jessie64:/usr/local/src/imscp-1.5.3-2018120800# systemd --version
    2. systemd 215
    3. +PAM +AUDIT +SELINUX +IMA +SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ -SECCOMP -APPARMOR

    The part which should fails

    Shell-Script
    1. ...
    2. [DEBUG] iMSCP::DbTasksProcessor::processDbTasks: Processing Modules::ServerIP tasks...
    3. [DEBUG] iMSCP::DbTasksProcessor::processDbTasks: Processing Modules::ServerIP tasks for: 192.168.1.133 (ID 1)
    4. [DEBUG] iMSCP::Execute::execute: /bin/systemctl is-enabled networking
    5. [DEBUG] iMSCP::Provider::Service::Abstract::_exec: enabled
    6. [DEBUG] iMSCP::DbTasksProcessor::processDbTasks: Processing Modules::ServerIP tasks for: 192.168.1.134 (ID 2)
    7. [DEBUG] iMSCP::Execute::execute: ip addr del 192.168.1.134/24 dev eth0
    8. [DEBUG] iMSCP::Execute::execute: ip -4 addr add 192.168.1.134/24 dev eth0
    9. ...

    So please first, upgrade your system. Latest Debian Jessie is 8.11, not 8.7.

    Shell-Script
    1. # apt-get update
    2. # apt-get dist-upgrade


    Once done, retry. If after that the problem still occurs, you'll have to provide me a access to the server for further investigation.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • freedom


    If you make a dist upgrade as stated in my previous answer this should solve the problem. The is-enabled API support for SysVinit scripts has been added lately in Debian Jessie systemd package:



    Basically put, you have an older version of the systemd package.


    Don't forget for the furture: Before updating i-MSCP, you need always update your system, as stated in the documentation.


    Latest systemd package under Jessie is:


    Shell-Script
    1. root@jessie64:/usr/local/src/systemd/systemd-215/debian# LANG=C apt-cache policy systemd
    2. systemd:
    3. Installed: 215-17+deb8u8
    4. Candidate: 215-17+deb8u8
    5. Version table:
    6. *** 215-17+deb8u8 0
    7. 500 http://security.debian.org/ jessie/updates/main amd64 Packages
    8. 100 /var/lib/dpkg/status
    9. 215-17+deb8u7 0
    10. 500 http://deb.debian.org/debian/ jessie/main amd64 Packages

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Nuxwin

    Added the Label unreproducible
  • Nuxwin

    Closed the thread.
  • badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Nuxwin

    Set the Label from unreproducible to patched