Update from 1.4.3 to 1.5.3: composer.phar Error

  • System: Ubuntu 16.04

    to prepare my server for an IP-change I tried to update i-MSCP 1.4.3 to the latest 1.5.3.

    I did apt-get update and dist-upgrade first, stopped running services

    # service cron stop

    # service imscp_daemon stop

    # pkill -TERM -f imscp

    and run the installer.

    It stopped with the message:

    [ERROR] iMSCP::Composer::_getComposer: Couldn't install/update composer.phar:

    [RuntimeException]SHA384 is not supported by your openssl extension, could not verify the phar file integrity

    Maybe it is not imscp-relatet but openssl or composer. But whilst it is preventing imscp from beeing installed or updated I hope to get some hints here.

    Thank you!


    Trying to get back the old Version, I learned that an i-MSCP downgrade is not supported. Any hints how I can get my webs online again whilst i-MSCP is not working?

    Edited once, last by symphosius: all my webs are down, so I tried to get back the old version. ().

  • symphosius

    This is a bug in composer due to openssl1.1.1 version changes.... Please try the following:

    1. Remove the /var/local/imscp/composer.phar file manually
    2. Run the i-MSCP 1.5.3 version installer with the --clean-package-cache command line option.



  • Thank you, Nuxwin, this worked so far. Now the installer runs into another error:

    [ERROR]Processing setup tasks Error was:

    main::setupDbTasks: Modules::ServerIP::add: Couldn't bring up the `eth0:1001' network interface: RTNETLINK answers: File exists at

    /usr/local/src/imscp-1.5.3/engine/PerlLib/iMSCP/Provider/NetworkInterface/Debian.pm line 100.

    ...propagated at /usr/local/src/imscp-1.5.3/engine/PerlLib/iMSCP/DbTasksProcessor.pm line 496.

    Please have a look at http://i-mscp.net/forum if you need help.

  • Hello

    please output of ifconfig

    Do you have configured the ETH Interface manually? Then, please also give us the full content of your /etc/network/interfaces file.

    Best regards

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.27 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • symphosius

    I've deleted your last answer. Please, use the right bbcode to suround your copy-past:

    [code]bla bla bla[/code]



  • I didn't configure the eth-interface manually.

  • symphosius

    Do you have configured the ETH Interface manually? Then, please also give us the full content of your /etc/network/interfaces file.

    Content of your /etc/network/interfaces file please...


  • I didn't configure the eth-interface manually. The /etc/network/interfaces reads:

  • symphosius

    Well, ifconfig show that the IP is configured on the eth0 interface:

    1. eth0 Link encap:Ethernet Hardware Adresse 4c:cc:6a:89:03:a6
    2. inet Adresse: Bcast: Maske:
    3. inet6-Adresse: fe80::4ecc:6aff:fe89:3a6/64 Gültigkeitsbereich:Verbindung
    5. RX-Pakete:7343336 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
    6. TX-Pakete:110085 Fehler:0 Verloren:0 Überläufe:0 Träger:0
    7. Kollisionen:0 Sendewarteschlangenlänge:1000
    8. RX-Bytes:496522860 (496.5 MB) TX-Bytes:10613929 (10.6 MB)

    I presume that it's the primary server IP. The problem is that in your /etc/network/interfaces file, that IP is not configured manually, and so, i-MSCP add a configuration stanza for it on an alias interface eth0:1001:

    1. # i-MSCP [] entry BEGIN
    2. auto eth0:1001
    3. iface eth0:1001 inet static
    4. address
    5. netmask 24
    6. # i-MSCP [] entry ENDING

    Of course, because the IP is already configured on the eth0 interface, this cannot work... Basically, you need to remove the above configuration stanza from your /etc/network/interfaces file and configure the IP manually. A stanza such as:

    1. auto eth0
    2. iface eth0 inet static
    3. address
    4. netmask
    5. broadcast
    6. gateway <your_gateway>

    should be OK. Don't forget to replace <your_gateway> by your gateway. Once done, retry the upgrade.


  • FloRet88

    Added the Label not a bug