ClamAV-MILTER not working after Update to ClamAV 0.100.0

  • Hallo,


    i have update ClamAV and then I can not send Mails or receive Mails.


    Log-File: mail.err


    Quote

    Jul 11 23:13:32 admin clamav-milter[14821]: Connection closed while reading from socket

    Jul 11 23:13:32 admin clamav-milter[14821]: No reply from clamd


    Log-File: clamav-milter.log


    Quote

    Wed Jul 11 22:03:42 2018 -> ERROR: Connection closed while reading from socket

    Wed Jul 11 22:03:42 2018 -> ERROR: No reply from clamd


    I must deactivate the ClamAV Plugin.


    I have deactivate and activate it again but it is not working.


    I become no error when I activate the Plugin.


    What can I do that ClanAV is working.


    ClamAV:



    Kind regards

    Viktor


    - Distribution: Debian | Release: 8.11 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 1.2.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.2)

    - LetsEncrypt (v 3.4.2), PhpSwitcher (v 4.0.3), RoundcubePlugins (v 2.0.1)

  • I have the same issue after upgrade from 1.5.1 to 1.5.3


    OS: Debian Jessie 8.11

    i-mscp 1.5.3

    ClamAV plugin: 1.3.0


    Solution (thanks to Viktor )

    Create a user.conf file under /etc/clamav-unofficial-sigs folder

    Code
    1. # Disable Yara rules for now because they are broken with clamav releases > 0.100
    2. yararulesproject_enabled="no"
    3. enable_yararules="no"

    Deactivate/reactivate ClamAV plugin

    i-MSCP 1.5.3
    Plugins (latest version): ClamAV, CronJobs, DomainAutoApproval, LetsEncrypt, OpenDKIM, PanelRedirect, PhpSwitcher, PolicydSPF, Postgrey, RecaptchaPMA, RoundcubePlugins, SpamAssasin, WHMCS