i-MSCP 1.5.x / RoundcubePlugins plugin 2.0.1 / Invalid working directory specified (Composer)

  • First my infos:

    OS: Debian jessy (8.10)
    imscp version: 1.5.x-konzeptplus
    PO server: dovecot
    roundcubeplugins version: 2.0.1

    After update to 1.5.x-konzeptplus my managesieve is not working anymore. After looking in the panel for the plugin status of roundcube-plugins it showed a unexpected error:

    1. Ein unerwarteter Fehler ist aufgetreten:
    2. Plugin::RoundcubePlugins::_installComposerPackages: [RuntimeException] Invalid working directory specified, =/var/www/imscp/gui/public/tools/webmail does not exist.

    I did check if the stated directory exist and it existed...

  • Please, try to fix the GUI permissions: perl /var/www/imscp/engine/setup/set-gui-permissions.pl
    Then trigger a retry through the plugin management interface.


  • Good morning @Nuxwin

    I have an equal incidence .. I have updated a panel from version 1.4 to the last 1.5.1 ...
    I tried to resolve with permissions, and and reconfiguring the plugin but the same error persists

    It's mounted on a Debian Jessie,

  • I'll give a try this evening.


  • Bug confirmed. This occurs after an update, when running imscp-autoinstall -dnv

    A retry (cliking on the 'Force Retry' button via plugin management interface) doesn't solve the issue.

    Well, I'll investigate and fix the issue. Once done, I'll provide you with instructions.



  • Problem found. This is due to wrong parameter value passed-in to composer.phar

    should be
    -d /var/www/imscp/gui/public/tools/webmail

    as specified by composer.phar:

    1. -d, --working-dir=WORKING-DIR If specified, use the given directory as working directory.

    Howto fix

    Edit the /var/www/imscp/gui/plugins/RoundcubePlugins/backend/RoundcubePlugins.pm file and change line 665:

    1. ."/var/local/imscp/composer.phar require --no-ansi -n -d=$webmailDir --update-no-dev "


    1. ."/var/local/imscp/composer.phar require --no-ansi -n -d $webmailDir --update-no-dev "

    Once done, save the file and force a retry through the plugin management interface.

    A new RoundcubePlugins plugin version will be released in next hours.


  • A new version of the RoundcubePlugins plugin has just been released. See PluginRoundcubes plugin v2.0.2 RELEASED

    Thread closed.