Let"s Encrypt Plugin /.well-known/acme-challenge/

  • Hi I installed the Let"s Encrypt Plugin, after installing and trying to enable a Cert I get the Message

    The /.well-known/acme-challenge/ URL path is not reachable for the techpedia.at domain. This can be either due to a DNS problem, or because you have an .htaccess file that rewrites the URL path to an unexpected location. In case of a rewrite rule, be sure to exclude the /.well-known/acme-challenge/ URL path by adding a rewrite condition such as RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/

    I have full DNS access also no rewrite

    has anyone a solution tried allready to find something in this Forum


    i-MSCP 1.5.1
    Build: 20170908
    Codename: Ennio Morricone

    Edited once, last by hwutti ().

  • Same here,

    already have some domains with LE working flawlessly, now added an alias domain with same mount point as the primary domain, getting mentioned error.

    I tried to remove all possible rewrites from that space as mentioned but no luck.

    Any advice?

  • What is the Let's Encrypt plugin version?

    Please post the appropriate log files for the plugin.

    Any other plugins installed?

    Please post any htaccess file, if present

    This way we have some more information to work with.

  • I am running plugin version 3.3.0

    I figured out the reason for me was a failb2ban apache rule, it blocked my own public ip from using port 443 locally. I temporary disabled fail2ban and it worked immediately then. Did not take further investigations yet what exactly was that rule and why it has been triggered, but maybe you should check your iptables for any active https input filter on your own interfaces.