Error Manage SSL-Certs for customer

  • Hello.


    Regarding the Let´s Encrypt Plugin, i run into following bug.


    When i logged in as customer and i would like to set up the HSTS Settings, i am not able to open the screen to edit this.


    i get following error message with activated debug mode:

    Brainfuck Source Code
    1. An unexpected error occurred
    2. An exception has been thrown in file /var/www/imscp/gui/plugins/LetsEncrypt/LetsEncrypt.php at line 205:
    3. Call to undefined method iMSCP_Plugin_Manager::getEventManager()

    Strange is, that no messages will posted in log-files.


    Have i missed an bug-report of this failure, or is there an actual bug in the plugin?
    My config / software you can see under the Support Infos (Signature)


    Best regards.

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.19 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • @FloRet88


    Good evening,


    I'll check the issue in few minutes and provide you with a patch if needed.

    Strange is, that no messages will posted in log-files.

    We are talking about PHP here. You expect to see the error in which log file exactly?


    BTW: Your Let's Encrypt plugin version is?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Good evening @Nuxwin! ;-)


    Thanks for checking.


    IMSCP Panel log, or Plugin log?


    LE Plugin version is 3.3.0


    Best regards.

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.19 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • IMSCP Panel log, or Plugin log?

    There is no log file and if you talk about admin log, there is no log for uncaught exceptions. ;)


    Well, I need ask you some details. please post us full content of the following files:

    • gui/library/iMSCP/Plugin/Manager.php
    • gui/plugins/LetsEncrypt/LetsEncrypt.php (this one in private please)

    Thank you.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Ok i understand.


    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.19 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • @FloRet88


    I'm just back from my shopping. Give me few minutes to take a little coffee.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Sure, no Problem!


    Don‘t hurry!

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.19 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • @FloRet88


    According the i-MSCP core file you provided me, you're not using i-MSCP 1.5.1...


    Error Manage SSL-Certs for customer
    while for 1.5.1, we have: https://github.com/i-MSCP/imsc…P/Plugin/Manager.php#L159


    getEventManager() vs getEventsManager()


    Can I have a look at the server to see what you have done exactly?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • @Nuxwin i will send you the informations tomorrow!


    Thanks for your hint of the I-MSCP Version, will Check it first!

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.19 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • @FloRet88


    Tomorrow morning, it's should be fine for me. Don't forget that I'm going away friday for my holidays ;)

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif