problem with plugins after server migration

  • I run in an unexpected error during activiting the plugin Postgrey. It remains in status "activating..."
    The rest seems to be running well, i have access to backend, all websites and e-mails.


    What happend before? I will try to explain short:

    • Fresh installation i-mscp 1.3.16, with all (postscreen, postgrey, spamasssin, clamav) compatible plugins needed, installed, but not activated.
    • Migration i-mscp 1.3.16 from one server to the new one, with the hints i found in this forum.
    • Part of some SQL-Commands was the command "update plugin set plugin_status = 'disabled', plugin_error = NULL;", followed by an "/var/www/imscp/engine/setup/imscp-reconfigure --reconfigure".

    Im looking for hints to solve that problem.


    • Where can i find the logs, wich will give me more ifnromationen of that unexpected error? /var/log/i-mscp it quite empty.
    • How can i change the status of the plugin to inactive, to try a deinsatllation and a new installation.
  • You must update your i-mscp to the last release before anything... no support for 1.3...
    And read the Readme file please :
    Postgrey plugin 1.2.0
    Requirements

    • i-MSCP Serie ≥ 1.4.x

    - Distribution: Debian | Release: 9.12 | Codename: stretch
    - i-MSCP Version: i-MSCP 1.5.3 | Build: 2018120800 | Codename: Ennio Morricone
    - Plugins installed: ServerDefaultPage (v. 1.3.0),Postgrey (v. 1.3.0), PolicydWeight (v. 1.3.0), ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), RoundCubePlugins (v 2.0.2), LetsEncrypt (v 3.5.0), PhpSwitcher (v 5.0.5), InstantSSH (v 5.0.1), CronJobs (v 1.4.1), PolicydSPF (v 1.2.0), Postscreen (v 1.2.0), Monitorix (v 1.2.2) & SpamAssassin (v 2.1.0)

  • Hmm, i didn't try to install last version of postgrey plugin on an old i-MSCP. That makes no sense. I use the old plugin version 1.1.1 wich runs in a fresh install of 1.3 without any problem.


    I just follow the few hints to migrate from one server to another, wich i found in the forum, ok, not the latest stable version, just the "old stable" version 1.3.16. But the hints makes no difference, wich version is used.


    I did the migration with same version of 1.3. because, i was not sure if 1.4 will run without problems on a "old" Ubuntu 14.04. PHP 7 is only one point, systemd an another point.


    So my plan was to uses a version wich will run on both systems, version 1.3.16. So i tested first if 1.3.16 will run on Ubuntu 16.04, with PHP7 and so on. And i installed all plugins, wich fits to version 1.3.16, and it works without a problem. So i migrate the data, the Database, mails and Websites to the new server, and it works, except the plugin postgrey. The other two plugins spamassassin and clamav are not clear at the moment.


    But i see, that postgrey is still running on the new server. The deactivation has not really deactivate the service. Ok, its another problem with the implementation of the plugins.


    At last, no support for 1.3 means no more hint or else for that in this forum. Ok, i got it.


    My server runs on one leg, but it still runs. I got a bit time to think about the right backup, crash and recovery scenarios and the proper combination of os and software wich will be able to solve that.