Frische Serverinstallation - "Couldn't restart the `imscp_traffic'

  • Hallo Leute,


    Leider läuft eine Installation nicht sauber durch, auf einem "neuen" VServer. Der Server selbst wurde von jemandem übernommen, der ebenfalls zuvor Imscp v 1.5.1 installiert hatte. Um nicht dessen Konfiguration übernehmen zu müssen, wurde der Server in den Restore versetzt und ein blankes Minimal-Ubuntu 16.04 installiert. Nach dem Restore um alle Fehler auszuklammern, wurde sofort eine frische IMSCP-Installation gestartet mit dem letzten stabilen Release 1.5.1, gemäß dieser Anleitung Imscp Installation. Diese Installation wurde mit folgendem Fehler abgebrochen:


    Code
    1. [ERROR] iMSCP::Stepper::_callback: Couldn't restart the `imscp_traffic' service: iMSCP::Provider::Service::Sysvinit::_exec: Job for imscp_traffic.service failed because the control process exited with error code. See "systemctl status imscp_traffic.service" and "journalctl -xe" for details. at /usr/local/src/imscp-1.5.1/engine/PerlLib/iMSCP/Service.pm line 227.[ERROR] autoinstaller::Functions::install: An error occurred while performing installation steps


    Das merkwürdige ist, die gleiche Installation wurde auf 3 anderen Servern des gleichen Anbieters (Hosteurope) mit der gleichen Konfiguration erfolgreich vollzogen. Der einzige Unterschied besteht in der Lage des Rechenzentrums. Die ersten 3 liegen in Europa, dieser Server in den USA.


    Weitere Informationen:

    Code
    1. systemctl status imscp_traffic.service● imscp_traffic.service - i-MSCP traffic logger Loaded: loaded (/etc/systemd/system/imscp_traffic.service; enabled; vendor preset: enabled) Active: failed (Result: exit-code) since Sat 2017-12-02 18:41:45 CET; 27min ago Process: 17551 ExecStart=/usr/bin/perl /var/www/imscp/engine/tools/imscp-net-traffic-logger start (code=exited, status=3) Main PID: 17551 (code=exited, status=3)Dec 02 18:41:45 server1 perl[17551]: [ERROR] main::start: ip6tables v1.6.0: can't initialize ip6tables table `filter': Table does not exist (do you need to insmod?)Dec 02 18:41:45 server1 perl[17551]: Perhaps ip6tables or your kernel needs to be upgraded.


    Code
    1. uname -r
    2. 4.4.0-042stab125.5

    IPv6 wurde weder vom Provider eingerichtet noch von mir aktiviert.


    Für Hilfe wäre ich äußerst dankbar.


    Beste Grüße
    Rabuntu

    Es gibt viele Wege Danke zu sagen, der Einfachste ist das auch zu tun.


    Herzlichen Dank - Merci beaucoup -- Большое спасибо -- Thank you very much -- Muchas gracias

  • @rabuntu


    This problem mostly occurs when the Kernel has been updated and that no reboot has been done while it was required.

    • If the vm is a container (OpenVZ or LXC): You need to reboot the host server.
    • If the vm is run through KVM hypervisor: You need to reboot the vm.

    Also, make sure that your vm is up-to-date before starting the i-MSCP installer: apt-get update && apt-get dist-upgrade


    Once done, rerun the installer.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • @Nuxwin


    Thank you for your answer. I've rebooted the server from commandline before. Now i test it from the Hostingprovider Panel, but i think that does not work too. I test it and i give response.


    Best regards
    Rabuntu

    Es gibt viele Wege Danke zu sagen, der Einfachste ist das auch zu tun.


    Herzlichen Dank - Merci beaucoup -- Большое спасибо -- Thank you very much -- Muchas gracias

  • Thank you for your answer. I've rebooted the server from commandline before. Now i test it from the Hostingprovider Panel, but i think that does not work too. I test it and i give response.

    If the VM is is an OpenVZ or LXC container, you need ask your provider to restart the host as restarting the VM will not have any effect for this specific problem. Provide him with the link to this post for explanation.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Thank you. :thumbsup:


    I've wroted one ticket to the 24/7 support. I'will give you more information about that, when support has answered.


    .

    Es gibt viele Wege Danke zu sagen, der Einfachste ist das auch zu tun.


    Herzlichen Dank - Merci beaucoup -- Большое спасибо -- Thank you very much -- Muchas gracias

  • Good morning @Nuxwin and @All,


    here the correspondence with the support.





    Steps to reproduce:
    1. I've started the setup from imscp per --reconfigure, same mistake.
    2. Afterwards, restore the server to clean MinimalUbuntu 16.04, setup imscp in "manual"-Mode --> Error with



    Code
    1. iMSCP::Stepper::_callback: Couldn't find the `PHP' command in search path at /usr/local/src/imscp-1.5.1/engine/PerlLib/iMSCP/Requirements.pm line 171.

    3. After that, i started setup in "auto"-mode again, same error as in Post 1.



    @Nuxwin
    If you want access to the server, please let me know or say me what i can do to give you more information, so that we can solve the problem together.


    Merci beaucoup pour vos efforts.

    Es gibt viele Wege Danke zu sagen, der Einfachste ist das auch zu tun.


    Herzlichen Dank - Merci beaucoup -- Большое спасибо -- Thank you very much -- Muchas gracias

    Edited 2 times, last by rabuntu ().

  • Hallo @Fiesling

    Das ist leider nunmal nen Problem bei manchen VPS Servern.

    Ja das glaub ich gern, allerdings irritiert mich daran, das auf anderen Servern mit der gleichen Grundkonfiguration beim gleichen Anbieter, eben alles reibungslos funktioniert.



    Quote from Fiesling

    Es scheint, als ob er nun das PHP nicht finden konnte - richtig installiert?

    Das mit dem PHP trat auf, als ich das Setup probehalber im "Manual"-Mode gestartet hab. Vielleicht hätte ich an der Stelle ein Tut verwenden soll, das sich auf diesen Modus bezieht. Sprich ich weiß bspw. nicht, ab wann der manuelle Modus greift, ob ich vorab die Pakete selbst installieren soll oder nicht, da muss ich mich erst schlau machen. Aber da ich bisher immer den "Auto"-Modus verwendet habe und anschließend gewohnt meine eigenen Konfigurationen vorgenommen hab, war für mich Manuell eigentl. stets obsolet. :)

    Es gibt viele Wege Danke zu sagen, der Einfachste ist das auch zu tun.


    Herzlichen Dank - Merci beaucoup -- Большое спасибо -- Thank you very much -- Muchas gracias

  • Kurze Erläuterung:
    VM wurde seitens des Supports Hardgestopt und gestartet, nächster Schritt Wirtssystem.

    Quote from Support

    Ich werde intern klären ob wir hier einen Neustart anbieten können, dies kann
    leider erst im laufe der nächsten Woche passieren. Ich bitte Sie daher noch um
    ein wenig Geduld.


    Hoffe wir bleiben alle weiterhin am Ball. :D

    Es gibt viele Wege Danke zu sagen, der Einfachste ist das auch zu tun.


    Herzlichen Dank - Merci beaucoup -- Большое спасибо -- Thank you very much -- Muchas gracias

  • @rabuntu


    For the PHP problem, this is due to the fact that installation was not complete... You cannot run the imscp-reconfigure script as long as i-MSCP has not been correctly installed.


    For the ip6table_filter problem, you could read also: https://github.com/moby/moby/i…05#issuecomment-307361421
    The issue reported is similar to the problem encountered with i-MSCP.


    Basically, the kernel modules are lazy-loaded on the host, meaning that if on the host, your provider has never used ip6tables, the required modules (here ip6_tables, x_tables) won't be available in your container.


    Your provider say that they don't use IPv6. I'm ok with that. However, IPv6 is not disabled in the container. i-MSCP detect IPv6 support by checking existence of the /proc/net/if_inet6 entry.


    I'll check your VM as soon as possible if you want. Provide me with the required data.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif