PHP Switcher new

  • When I install the PhpSwitcher did i have to upgrade my PHP5.6 to PHP7.2 before or can I use it on the old PHP version ?

  • When I install the PhpSwitcher did i have to upgrade my PHP5.6 to PHP7.2 before or can I use it on the old PHP version ?

    What do you mean exactly? The PhpSwitcher plugin make it possible to provide many PHP version to customers. The default PHP version used on your system is not relevant for that plugin.



    BTW: The PHP 7.2 version is not stable yet, not supported by i-MSCP yet, not provided by the PhpSwitcher plugin yet ;)

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Last Question


    PhpSwitcher can be used per site ......
    do I understand ir right :


    domain1.tld = PHP7.1.x
    sub.domain1.tld = PHP 5.6
    sub.domain1.tld = PHP 7.0.x


    thx for answer

  • domain1.tld = PHP7.1.x
    sub.domain1.tld = PHP 5.6
    sub.domain1.tld = PHP 7.0.x

    Yes. For that, you must have chosen the per site level while installing i-MSCP. You can always reconfigure the level by running:

    Code
    1. perl /var/www/imscp/engine/setup/imscp-reconfigure -dar php

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206