Let`s Encrypt Error for control panel

  • Hello ,
    After update to 1.5.0 i have a problem with activating my SSL for admin panel.

    1. The /.well-known/acme-challenge/ URL path is not reachable for the my.admin.panel domain. This can be either due to a DNS problem, or because you have an Apache2 rewrite rule somewhere that rewrites the URL path to an unexpected location. In case of an Apache2 rewrite rule, be sure to exclude the /.well-known/acme-challenge/ URL path by adding a rewrite condition such as RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/

    Any idea why that?

    Linux Distro: Ubuntu Xenial XerusI-MSCP : 1.5.0
    Plugins: ClamAV, LetsEncrypt, Mailgraph, Monitorix, OpenDKIM, Postgrey, RoundcubePlugins

    OpEn YouR mINd , OpeN YouR SourcE cOdE

  • Hello,

    I also can confirm the problem with 1.5.0 and activated PHPSwitcher and LE plugin on Debian 9.0!

    @Nuxwin Tomorrow i can provide you the log files!

    I temporary solved the problem with deactivating PHPSwitcher Plugin. After then, it works like a charm!


    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.27 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • I temporary solved the problem with deactivating PHPSwitcher Plugin. After then, it works like a charm!

    Can you clarify a bit? I don't see the relation between the PhpSwitcher plugin and the Let's Encrypt plugin here... Please provide the exact steps to reproduce.

    The error quoted in the first post is clear enough. The LetsEncrypt plugin frontend is unable to access the .well-known/acme-challenge/ folder (the one from the plugin) through the domain for which he want activate Let's Encrypt. This generally occurs when there is a rewrite rule somewhere that do an unexpected rewrite on the .well-known/acme-challenge path, or, and that is surely the case of @All, when the site is not reachable locally (from the server itself).

    I've already planned to remove that local test in next LetsEncrypt plugin version. However, such error should not occurs if the server is configured correctly.


  • @Nuxwin so what i need to do ? For every domain plugins work like a charm.
    I did`t change anything from last time where you configure, i just make update from 1.4.7 to 1.5.0.

    OpEn YouR mINd , OpeN YouR SourcE cOdE

  • @All

    Fixed. This was due to your facts... You should avoid to setup additional vhosts manually without thinking more.

    I had to remove the configuration files that you have manually created :

    • /etc/apache/imscp/before/00_mail.conf
    • /etc/apache/imscp/before/00_webmail.conf
    • /etc/apache2/sites-available/00_mail.conf

    When you create a vhost manually, don't forget to discard the ./well-known path from any redirection or proxy. Generally speaking you should avoid create configuration file manually, except if you really know what you're doing.

    Once I've removed those files and restarted Apache all wen't fine.


  • @Nuxwin yeah but i know see something else, when i type into address bar my hosting panel address and then redict me somewhere else.

    Any idea why that

    OpEn YouR mINd , OpeN YouR SourcE cOdE

  • You hosting panel URL is: https://admin.hostcom.org:4443
    All is working fine from my location.