Upgrade zu stretch Error

  • Hallo,


    wollte auf einem Testsystem zu stretch upgraden.
    Nach dem Upgrade habe ich den imscp Installer wieder ausgeführt und erhalte folgende Meldung:




    Hat schon jemand auf stretch aktualisiert?

  • kannst du bitte die vollständige Log-Datei mitgeben /var/log/imscp/imscp-autoinstall.log
    ich vermute der eigentliche Fehler ist nach dem "......." sichtbar


    edit: ja, ich habe eine Test VM mit Stretch eingerichtet, allerdings eine frische, kein Upgrade von früherem Debian.

  • @Bulli


    What steps did you following exactly to upgrade to Debian Stretch?


    Result of the following commands please:

    • apt-cache policy openssl
    • apt-cache policy php-pear

    Did you read that post ?


    Here, you're facing a distribution upgrade issue which you should fix outside of i-MSCP installer. I'll not add the --allow-change-held-packages flag because this could cause dammages.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Hi,
    the one different -> i've said always no to update the config files.

    Code
    1. openssl: Installiert: 1.0.2j-1+0~20161013114109.8+stretch~1.gbpac057a Installationskandidat: 1.0.2j-1+0~20161013114109.8+stretch~1.gbpac057a Versionstabelle: 1.1.0f-3 500 500 http://ftp2.de.debian.org/debian stretch/main amd64 Packages *** 1.0.2j-1+0~20161013114109.8+stretch~1.gbpac057a 1001 1001 https://packages.sury.org/php stretch/main amd64 Packages 100 /var/lib/dpkg/status
    Code
    1. php-pear:
    2. Installiert: 1:1.10.1+submodules+notgz-8+0~20160602114123.2+stretch~1.gbp916245
    3. Installationskandidat: 1:1.10.1+submodules+notgz-8+0~20160602114123.2+stretch~1.gbp916245
    4. Versionstabelle:
    5. 1:1.10.1+submodules+notgz-9 500
    6. 500 http://ftp2.de.debian.org/debian stretch/main amd64 Packages
    7. *** 1:1.10.1+submodules+notgz-8+0~20160602114123.2+stretch~1.gbp916245 1001
    8. 1001 https://packages.sury.org/php stretch/main amd64 Packages
    9. 100 /var/lib/dpkg/status
  • @Bulli


    Try apt-get dist-upgrade manually and say yes for downgrade. Once done, rerun the i-MSCP installer.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Same error (try with yes)

  • @Bulli


    Not really the same error since target package are not same...
    Could you give me access to the server?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Problem behoben. Danke Nuxwin !


    Es wurden manuell das Paket libpam-mysql "unholded": apt-mark unhold libpam-mysql
    Danach erneut das Setup ausgeführt.