I-mscp and special caracters (diacritic)

  • Hello, everyone.

    Here in Romania our TLD offer the possibility to register and use domain name with special characters (diactritic) ex: viseîmplinite.ro.
    Unfortunately we notice that the domain name was incorrect written inside the bind, apache and other conf files. Any idea how to solved this problem? Does i-mscp support special characters?

    Thank you.

  • @Delta04

    First: Reporting rules - Reminder

    Unfortunately we notice that the domain name was incorrect written inside the bind, apache and other conf files.

    What is the value that has been inserted?

    BTW: xn--visemplinite-8fb.ro is the punnycode form (ascii) of the viseîmplinite.ro IDN. IDN are never put AS THIS in the bind conffileS, Apache vhost files or Postfix conffiles... This is expected. And yes, i-MSCP support IDN.

    See also: http://idna-converter.com/


  • You are killing me with the reporting rules.

    • When you want report a problem, you must create your own thread to avoid to pollute other discussions

    Done. Thread created.

    • You must ensure that the problem is not fixed yet in latest released version or development branch for latest serie

    I search the forum and did not find anything related.

    • You must create exactly one thread per problem

    Single thread created. It was more like a question and not sure if it's a problem.

    • You must give us the following informations:

    • The i-MSCP server implementation in use for the concerned service (for instance: ITK, Fcgid, PHP-FPM, Proftpd, Vsftpd ...)

    i-mscp 1.3.0 on ubuntu 14.04 LTS. Bind, Apache...

    • The plugin name and its version if your problem belongs to a plugin

    I don't think is a plugin related problem. I use the following plugins: ClamAV, OpenDkim, RoundCube plugins, SpamAssassin.

    • A understandable description of the problem

    The description of the problem (if there is one) I mention it above, on the first thread.

    • The service logs (generally located under /var/log)

    If you consider it is necessary, I'll search the logs for some related lines.

    • The exact steps to reproduce the problem

    I just created the client account by clicking Add Customer.

    • If your problem is considered a bug by our team, you must create an issue on our bug tracker

    Not sure if it's a bug...

    Happy? :)

    Indeed, that's how it wrote xn--visemplinite-8fb.ro.

    Using dig command, here is what it display

    root@server:/home/ubuntu# dig viseîmplinite.ro

    ; <<>> DiG 9.9.5-3ubuntu0.8-Ubuntu <<>> viseîmplinite.ro
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 9221
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

    ; EDNS: version: 0, flags:; udp: 4096
    ;vise\195\174mplinite.ro. IN A

    ro. 1799 IN SOA primary.rotld.ro. hostmaster.rotld.ro. 2013783170 10800 3600 604800 3600

    ;; Query time: 45 msec
    ;; SERVER:
    ;; WHEN: Wed Aug 31 10:36:27 EEST 2016
    ;; MSG SIZE rcvd: 107

  • You are killing me with the reporting rules.

    You have to enter translated domain name when creating domain in panel, eg. viseîmplinite.ro should be xn--visemplinite-8fb.ro.

    Check here: https://www.punycoder.com/

    I have domains with polish characters and they're working fine, they just should be set using punycode instead of classical IDN.