PhpSwitcher & mariaDB

  • hello

    I have a problem with PhpSwitcher when I try to install PHP7.0 with perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/ 7.0

    I have the following error

    1. Some packages could not be installed. This may mean that you have
    2. requested an impossible situation or if you are using the unstable
    3. distribution that some required packages have not yet been created
    4. or been moved out of Incoming.
    5. The following information may help to resolve the situation:
    6. The following packages have unmet dependencies:
    7. libmariadb-client-lgpl-dev-compat : Conflicts: libmysqlclient-dev
    8. [FATAL] main::builddeps: An error occurred while installing build dependencies: E: Unable to correct problems, you have held broken packages.

    How can I fix this problem ?

  • @xavh90

    • i-MSCP version?
    • PhpSwitcher plugin version?
    • MariaDB version?
    • Distro and its codename


  • @xavh90

    Please try:

    1. # apt-get purge libmysqlclient-dev
    2. # apt-get install libmariadb-client-lgpl-dev-compat

    Once done, rerun the compiler.


  • Please, give me an access to the server.


  • @xavh90

    Problem fixed on your server.

    Two packages were in conflict:

    The libmariadbclient-dev package which is provided in MariaDB repository (not Debian repository)
    The libmariadb-client-lgpl-dev-compat package which is provided by Debian (In Debian Repository)

    To solve the problem, and because you use MariaDB from external repository (MariaDB respository), I've simply commented the libmariadb-client-lgpl-dev-compat package in the PhpSwitcher PHP compiler.

    I'll add a fix in next PhpSwitcher plugin version to avoid such a problem.

    Thank you for your report.


  • So, Nuxwin resolved the problem of php compilation on my server but

    I registered the PHP7.0 version in PhpSwitcher plugin

    When I switch to PHP7.0 on a domain or subdomain, I have a 503 error service unavailable

    The phpinfo in PhpSwitcher is good with php7.0.8 and the status is "OK"

    Edit :

    I have this error in the /var/log/phpswitcher/psw7.0-fpm.log file

    [14-Jul-2016 12:29:16] ERROR: unable to bind listening socket for address '/var/run/phpswitcher/': No such file or directory (2)

    Edited once, last by xavh90 ().

  • Hi xavh90!

    I think u must disable and reactivate the PHP Version once. That should solve the problem.

    Hope that helps.

    Best regards.

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.27 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)