Reconfigure SQL Server failes - 1.3.x Branch

  • @batZend


    The problem is that i-MSCP itself don't remove data for the SQL root user. I need really investigate more...


    Please, can you give us more info about your environement, specially:


    • SQL server and version in use
    • Distro and codename

    Thanks.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • sql version


    Code
    1. +-----------------+
    2. | VERSION() |
    3. +-----------------+
    4. | 5.5.49-0+deb8u1 |
    5. +-----------------+

    Debian 8.5 jessie


    -----


    the [email protected] must be removed during upgrade to 1.3.0 as the login worked for installation and creating imscp_user but not after.

  • I used mysql server 5.7
    Debian 8 Jessie

  • Any additional info i can give you?
    I'm right that i manually add host localhost to fix this, or will this fixed with a patch?


    Code
    1. GRANT ALL PRIVILEGES on *.* to 'root'@'localhost' WITH GRANT OPTION;


    should do the fix or?

  • @batZen


    You can ;) We must investigate more to be able to fix. The installer don't remove the entry itself.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206