(SOLVED) Cant Update -- Unknown column 'domain_dns_status' in 'where clause'

  • Old Server 1.2.2 to New Server 1.2.9.
    I follow the execlent Migration Guide on GitHub (b13n1u/1109474), everything went fine until

    1. perl /var/www/imscp/engine/setup/imscp-setup -d

    It exiting with Error:

    1. "[ERROR] main::setupRebuildCustomerFiles:
    2. Error while rebuilding customers files: [ERROR] main::_process: Error while processing 1, xxxxxxx.de, tochange.
    3. main::_process: See /var/log/imscp/Domain_module_xxxxxx.de.log for more details.
    4. Modules::Domain::add: Error while executing statement: Unknown column 'domain_dns_status' in 'where clause'

    The domain has nothing special, just 2 Wordpress.

    • Server-Version: 10.0.22-MariaDB-0+deb8u1 - (Debian)
    • Datenbank-Client Version: libmysql - mysqlnd 5.0.11-dev - 20120503 - $Id: 3c688b6bbc30d36af3ac34fdd4b7b5b787fe5555 $
    • PHP-Erweiterung: mysqli
    • PHP-Version: 5.6.14-0+deb8u1

    Edited once, last by BudSpencer ().

  • Please have a look if the column domain_dns_status exists

  • No there issent column "domain_dns_status", just "domain_dns"
    i do not understand why "imscp-setup -d " is looking for "domain_dns_status"

    Where is i-mscp looking for it, so i can create it manuel.

    Edited once, last by BudSpencer ().

  • No there is now column domain_dns , in wic Table i must create it the column domain_dns.

    Thank you.

    Über etwas Hilfe wäre ich echt dankbar.

  • If you want, send me the credentials. I'll try to fix your upgrade problem later..

  • Solved (thx to Ninos).
    It seems i dident change the IP Adresse from the Old Server.
    This Broke the Migration.

    Its Realy Important to change the IPs in the MYSQL Database, not just in the Config Files.