Postscreen 1.2.0

PluginManager -

Plugin allowing to use Postscreen daemon with Postfix on i-MSCP.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

Plugin allows to use Postscreen daemon with Postfix on i-MSCP.
wiki.i-mscp.net/doku.php?id=plugins:postscreen
Images
  • Postscreen_1.jpg

    88.45 kB, 1,278×676, viewed 2,074 times
  • Postscreen_2.jpg

    110.99 kB, 961×816, viewed 2,081 times
  • Version 1.2.0

    - 12.01 kB - 33 times downloaded

    Version compatible with i-MSCP Serie ≥ 1.4.x

    CHANGELOG
    • Removed: Support for i-MSCP 1.3.x Serie
    • Review: Refactored code (backend)
  • Version 1.1.2

    - 12.23 kB - 87 times downloaded

    Version compatible with i-MSCP 1.3.x Serie or 1.4.x Serie

    CHANGELOG
    • Fixed: `POSTFIX_VERSION' parameter not available in Serie 1.3.x
    • Fixed: Plugin cannot be reinstalled if it has been uninstalled
    • Fixed: Plugin cannot been uninstalled
  • Version 1.1.1

    - 12.04 kB - 21 times downloaded

    Version compatible with i-MSCP 1.3.x Serie or 1.4.x Serie

    CHANGELOG
    • Removed: Dead blacklist spamtrap.trblspam.com
    • Updated: DNS blacklist and whitelist domains
  • Version 1.1.0

    - 11.87 kB - 286 times downloaded

    Version compatible with i-MSCP 1.3.x Serie

    CHANGELOG
    • Added: NiX Spam (ix.dnsbl.manitu.net) to DNS blacklist test
    • Added: Postfix version check
    • Added: Postscreen dnsbl whitelist threshold
    • Changed: Align Postscreen main.cf entries for Postfix
    • Changed: Switch Postfix service restart to reload
    • Fixed: Postfix (>= 3.0) is showing many warnings about backwards-compatible settings (default setting chroot=y)
    • Removed: Experimental smartmatch operator
    • Removed: Postfix version check on installation (all supported distributions provide Postfix > 2.8)
    • Updated for i-MSCP 1.3.x Serie
  • Version 1.0.0

    - 11.42 kB - 366 times downloaded

    Version compatible with i-MSCP >= 1.2.3

    CHANGELOG
    • Added: LICENSE file
    • Fixed: Don't harcode service configuration file paths
    • Fixed: Don't replace smtp service already in master.cf file ( Last definition has higher precedence )
    • Removed: Support for i-MSCP 1.1.x serie
    • Removed: Mailgraph patch ( Non compliant to the i-MSCP development policy )
  • Version 0.0.5

    - 10.03 kB - 243 times downloaded

    Version compatible with i-MSCP version >= 1.1.22 for the 1.1.x serie or >= 1.2.1 for the 1.2.x serie ( Plugin API >= 0.2.16 )

    CHANGELOG
    • Fixed: Removed policyd-weight & postgrey
    • Fixed: Catch whether Roundcube is installed
  • Version 0.0.4

    - 10.25 kB - 183 times downloaded

    Version compatible with i-MSCP >= 1.1.0

    CHANGELOG
    • Fixed: Roundcube version 1.x renamed main.inc.php to config.inc.php
  • Version 0.0.3

    - 9.96 kB - 242 times downloaded

    Version compatible with i-MSCP >= 1.1.0

    CHANGELOG
    • Fixed: my variable $rs and $rdata masks earlier declaration
  • Version 0.0.2

    - 9.92 kB - 201 times downloaded

    Version compatible with i-MSCP >= 1.1.0

    CHANGELOG
    • Fixed: Uninitialized value $policyService
  • Version 0.0.1

    - 9.85 kB - 264 times downloaded

    Version compatible with i-MSCP >= 1.1.0